Building OP-TEE for LeMaker board


#1

Hi,

I have the 2gb LeMaker version of the board and am having some trouble with these instructions: https://github.com/96boards/documentation/wiki/HiKeyOPTEE. I get to Build UEFI for HiKey but it fails the uefi-build.sh portion with the following:

mk/config.mk:95 *** Could not partse TEE_IMPL_VERSION (8a933cc), expected format: <major>.<minor>[anything else}. Stop.
CircuitCo HiKey RELEASE fail
pass 0
fail 1

There doesn’t seem to be an entry in platform.config for the LeMaker version. This stops the generation of fip.bin so there is no way to proceed from here.

Anybody encounter this?


#2

There is no need to have a separated entry for the LeMaker version, as it should just work with the current one.

This issue that you had is because the instructions points out to the master/development tree for OP-TEE, and there is indeed an issue now that you need to export “TEE_IMPL_VERSION”, otherwise it fails to build.

Try “$ export TEE_IMPL_VERSION=1.1.0” before calling the build command and see if it works better.


#3

Another alternative is to try deleting the optee_os/out directory and rerun the uefi-build.sh script.


#4

@Ricardo Thanks. export TEE_IMPL_VERSION=1.1.0 fixed it. I was hoping it was the case that the entry was the same, but luck wasn’t what I was gonna hang everything on.

@vchong I didn’t have the optee/os directory, but that will be helpful if I run into this issue from this point. Thank you.


#5

Update: Cloning with a depth of 1 will cause the parse (git) command for TEE_IMPL_VERSION to generate the improper version string. Please clone without --depth option.


#6

Update: Bug has been fixed so cloning with any depth is fine now.