Bricked hikey board


#1

hey guys, i’m having trouble with an hikey board i have.
it seems as the board is dead, it is not responding at all.

I’ve tried putting it in fastboot mode, and nothing, no recovery, leds don’t come on at all.


#2

I had once a similar experience. I played around with the jumper settings and hit once jumper setting configuration which did not work. After using a different jumper settings configuration the board was again “alive”.

Have you checked your jumper settings configuration?

https://github.com/96boards/documentation/blob/master/hikey/HiKey_User_Guide_Rev0.2.pdf?raw=true


#3

Yes, jumpers 1-2 are closed and 3-4 as well.

I hooked the board using the otg connector to my pc, powered it on but nothing showed up in dmesg.

All UART jumpers are open.


#4

Jumpers closed 1-2, 3-4 is exactly the configuration which does not work from my experience. Have a look at the fastboot installtion instructions: https://github.com/Linaro/documentation/blob/master/Reference-Platform/RPOfficial/ConsumerEdition/HiKey/InstallDebianRPB.md#step-4-install-debian-using-fastboot-with-linux-host

Jumpers closed 1-2, 5-6 and open 3-4 than you can work with fastboot. To run the OS on the board Jumpers closed 1-2 and open 3-4, 5-6.


#5

tried 1-2,5-6 to get to fastboot, didn’t work.
tried 1-2 also doesn’t work.

lenovator support offered me to try using UART, but i still need a cable for it.


#6

so i followed this guide:
http://www.96boards.org/forums/topic/short-intro-to-start-your-hikey-with-serial-console/

and couldn’t get anything from the UART debug port.

the weird thing is that the prompt rectangle stops blinking the minute i power the board.

anyone had seen this ?