Audio Mezannine Board mics are not working on DragonBoard 410c

  • I have connected the Audio Mezzanine Board to the DragonBoard 410c.

  • I have set Switch 1 on the Audio Mezzanine Board to the ON position and set Switch 2 on the Audio Mezzanine Board to the 5V position.

  • I have set Switch 6-3 under the DragonBoard 410c to the ON position.

  • In the software part, I have downloaded the necessary supporting packages by running the commands in the document.

  • I have changed Input Devices as Secondary Microphone (I have also tried Digital Microphone) in the Sound & Video settings.

  • Now I am trying online SPEECH TO TEXT to test audio capture with my analog and digital mic on audio Mezannine board.

  • I was not able to capture the Audio with both Digital and Analog mics. Please help me to capture audio from Analog and Digital mics on the Audio Mezzanine board.

Thanks in Advance.

P.S: Audio capture works fine with earphones.

The switches are irrelevant when it comes to the dragonboard audio features.

No idea what “necessary supporting packages” you think are required, or what those commands you ran are… link to a guide or something that you are following?

There are two microphones on the board, one is digital, the other is analog. There is a third microphone supported by the board connected to the “audio jack”.

Now here is the fun part… the digital microphone is wired up to UART0, so to make that work, you would have to muck around in the kernel and reassign the pins to microphone. The analog microphones could work, but you will have to make sure to set the proper routing for the microphone you are trying to use.

I would suggest that rather than using some kind of speech to text program for testing, you just try to capture the raw audio with arecord.

Thanks @doitright for your inputs.

I am mainly concentrating on Analog mic. Please highlight what is meant by “make sure to set the proper routing for the microphone you are trying to use”. In Sound & Video settings, I have assigned Input Devices port as Secondary Microphone.

I have also tested with arecord, but I could only hear some noises.

Have you seen older threads about mic: Analog MIC initialization on Linaro distribution

@Loic Thanks for sharing the link, I have tried recording the voice using the commands(arecord) given in the link. WAV file is getting generated, but while playing only noise is audible.

If you are getting noise, it’s probably reading from the wrong microphone, i.e., the jack instead of the built in microphone. Try plugging an external microphone into the board and see if that works. If it does, it means you need to alter the routing to pick up the other microphone.

Thanks for your input,
@doitright, Thanks for your input.

amixer cset iface=MIXER,name=‘ADC2 MUX’ 'INPx’

Is this the command to alter the routing to pick up the other microphone. If not, please throw some light on it.

Maybe. I don’t know the audio details of the board well enough to tell you how to set up the mixer.

The third post in the thread linked by @Loic I think has the details you are looking for.

@doitright and @loic, things got working. I could record the audio using the analog mic. Thanks for your inputs.

Nice, what was the problem, could you share the right commands.