Any way to force HDMI on with no monitor detected?


#1

The problem is that hotplug doesn’t work, which means that if the monitor doesn’t respond early enough in the boot, then the HDMI will never turn on.

I’d like to tell it to turn on the HDMI regardless of whether or not some monitor has been detected.

I’m currently using video=HDMI-A-1:1280x800@60 , which is unfortunately not sufficient.

Edit: also tried using video=HDMI-A-1:1280x800R@60e – still no, despite this;

# cat /sys/class/drm/card0-HDMI-A-1/enabled                                      <
enabled

#2

Not 100% sure it will work but you could try adding drm_kms_helper.edid_firmware=edid/your_edid.bin to the kernel command line. You’ll have to arrange for edid/your_edid.bin to in the initramfs so the kernel can load it (your_edid.bin can just be copied from a working system: /sys/class/drm/card0-HDMI-A-1/edid).


#3

Unfortunately, that made no difference at all.


#4

this cat CMD is useful! Thanks!


#5

Hmnnn… you could try adding a ‘D’ alongside the ‘e’ but, given this is a digital only connector and sysfs already thinks its enabled, I’m don’t really think this will make any difference.

In fact with sysfs concluding it is enabled I’m afraid you might be forced to drill down into the driver source itself. All I can say is that setting the appropriate drm.debug=X bits can be very valuable in figuring out which bits of driver source are the ones that matter!