Any good way to prevent wpa_supplicant from starting at boot up?

I am able to stop wpa_supplicant using service wpa_supplicant stop command. Any way I can prevent it from starting at boot up? Many thanks.

AFAIR, wpa_supplicant is started by NetworkManager, you can configure the wireless interface as ‘unmanaged’ [1] but not sure it will prevent NM to run wpa_supplicant. If you don’t need network you can also just disable NM.


Hi Loic,

Thank you for the reply. It worked.

I also find another way to disable wpa_supplicant, which is to comment execute line in /lib/systemd/system/wpa_supplicant.service.

any side effects of modifying wpa_supplicant.service file?