Android not booting


#1

Hi

Debian works flawlessly with my DragonBoard. Android, however, does not even boot. Flashing the eMMC was ok, after having started the board all I got a short flash of (one of?) the blue LED, then LED 4 goes on and stays on for a minute or so. And that was it. S6 setting is 0-0-0-0, the SD is removed, I have tried several (native 1080) monitors and SD cards. I haven’t got a serial converter so I don’t know what the console says.

Any ideas what might be wrong?

Peter


#2

Hi Peter,
For better results, please make sure the Monitor is plugged in before the boot up happens.

We have observed that the first boot up of Android release after a full flash takes slightly longer than subsequent boots. Please allow about 2-5 minutes before the complete initialization happens after re flash and boot.

Also, can you connect a Micro USB to the Micro USB port and install Vysor on your PC Host.
Vysor can be installed in Chrome browser from here:
https://chrome.google.com/webstore/detail/vysor-beta/gidgenkbbabolejbgbpnhbimgjbffefm?hl=en-US

thanks
Sujai.

Full Disclosure: I am an employee of Qualcomm SanDiego. Any opinions expressed in this or any other post may not reflect the opinions of my employer


#3

Hi Peter:

I see you are ‘changing’ from Ubuntu to Android. The fist level bootstrap loaders on the two operating systems are slightly different (and end up being incompatible). If you install the OS from a SDCard it will change everything including the first level bootstrap loaders (or at least that was the case last time I tried it). Ass far as I can tell, if you are installing with fastboot over USB, you can only update the operating system, you cannot change operating systems. The first level bootstrap loaders are only available inside the SDCard installer. Reload your system with Android from a SDCard and you should be fine.

Finally as Sujai has noted, the first time Android boots it is a real test of patience, wait 3-5 minutes.

Remember to update your MAC address after you reload the OS.

Full Disclosure: I am an employee of Qualcomm Canada. Any opinions expressed in this or any other post may not reflect the opinions of my employer.


#4

Hi sujay and ljking,

Thanks for your replies.

I used the SD method, waited for 20 minutes or so and plugged the monitor before powering the DragonBoard. I will look what Vysor says.

Regards

Peter


#5

Pebol, any luck with this? I’m having the same issue.


#6

I am having the same issue and looks like there is no resolution to this… has any one found other boards that are better suited to run Android? Following the GitHub instructions to the T, twice, and still have nothing after a 15 minute allowance of time to boot.


#7

I am having the same issue. Will try Debian now since I am getting nowhere with the Android image.

Also use the uSD card installation (several times by now) and definitely have the monitor (1080p) connected before I power on the board. Switches are 0110 for installation and 0000 for boot after the installation.

EDIT And I waited ~20 minutes for Android to boot, screen stayed black, only other observation is that USB keyboard and mouse seem to get power (red light on mouse is on).

EDIT2 Followed the same procedure to load the Linaro image onto uSD card and install the same way and Linaro is working flawlessly from eMMC memory. Could this be a broken Android image causing this issue?


#8

Just went to the Downloads section for the DragonBoard 410c and noticed that the Android image there for download is now is the first one in the list (build 99) and previously the not working one is the second one in the list (build 118).

  • dragonboard410c_sdcard_install_android-99.zip
  • dragonboard410c_sdcard_install_android-118.zip

So could be that the 118 build was indeed not working. Will try the process again with build 99 after it’s downloaded.


#9

Just finished the process with Android build 99 and it indeed does boot. This problem is solved by downloading the current image for Android.

Would have been nice for whoever posted the old image to post a notification that build 118 was not working (then again, maybe I missed the notice).


#10

I am having the same issue. Where can i find the 99 download. I have looked online and I am not able to see it.

Thanks


#11

If you can provide the link I think that would be helpful to other developers but as of right now I am calling it… I have talked to the disturber for Arrow and they are willing to take the boards back. This seems to be a big issue for other developers as well. Its to bad, on paper this is a great solution to an issue I am having but it is no longer worth the time and effort. Returning my boards, I recommend finding another board to run Android.


#12

I used this link from the Downloads section for the board here on 96boards:
http://builds.96boards.org/releases/dragonboard410c/qualcomm/android/16.03/dragonboard410c_sdcard_install_android-*.zip

For me this currently resolves to:
https://publishing-96boards-org.s3.amazonaws.com/production/releases/dragonboard410c/qualcomm/android/16.03/dragonboard410c_sdcard_install_android-99.zip?Signature=exAn%2BUvR5HGhY5agNSCiKarUsSI%3D&Expires=1476132794&AWSAccessKeyId=AKIAI7SYFRRWYCCLG3YQ

This is a sign AWS S3 URL so will not be the same for you but you can see in the file name that it references build 99.

Good luck with that, the first URL should resolve successfully for you too.


#13

Would also be interesting to see whether the fastboot image files work and whether those install a newer build, might only be a bundling issue.


#14

Michael,

Thank you for your solution. It now boots fine with Android build 99.

Lots of issues with Android and the Dragonboard, which I find very disappointing.


#15

Yes thank you Michael. That was a big help.

Best.


#16

The folder is in http://builds.96boards.org/releases/dragonboard410c/qualcomm/android/

I guess we just have to wait for the next version…