Android : lcd backlight control


#1

Hi.

Device tree was added to confirm display.
But the backlight is not controlled.
Backlight is being used by connecting to mpps 4, but the pulse can not be checked.
Where do I need to modify settings that are compatible with Android brightness control?

========= cut ===========================
qcom,mdss-dsi-bl-min-level = <1>;
qcom,mdss-dsi-bl-max-level = <4095>;
qcom,mdss-dsi-dma-trigger = “trigger_sw”;
qcom,mdss-dsi-mdp-trigger = “none”;
qcom,mdss-dsi-bl-pmic-control-type = “bl_ctrl_pwm”;
qcom,mdss-dsi-bl-pmic-pwm-frequency = <100>;
qcom,mdss-dsi-bl-pmic-bank-select = <0>;
qcom,mdss-dsi-pwm-gpio = <&pm8916_mpps 4 0>;
qcom,mdss-dsi-reset-sequence = <1 10>;
========= cut ===========================
mpp@a300 { /* MPP 4 /
/
Backlight PWM /
qcom,mode = <1>; /
Digital output /
qcom,invert = <0>; /
Disable invert /
qcom,src-sel = <4>; /
DTEST1 /
qcom,vin-sel = <0>; /
VPH_PWR /
qcom,master-en = <1>; /
Enable MPP */
};
========= cut ===========================

Thank you in advance.


#2

Hi,

Can you please check " qcom,mdss-dsi-bl-pmic-control-type = “bl_ctrl_pwm”; " is added into your panel dtsi file in kernel and let us know,

Thanks
Ramesh


#3

Thank you for your response.
/////////////////////////////////////////////////////////
qcom, mdss-dsi-bl-pmic-control-type = “bl_ctrl_pwm”;
qcom, mdss-dsi-bl-pmic-pwm-frequency = <100>;
qcom, mdss-dsi-bl-pmic-bank-select = <0>;
qcom, mdss-dsi-pwm-gpio = <& pm8916_mpps 4 0>;
/////////////////////////////////////////////////////////
As written above, the display (dtsi) file has been modified.

mdss_dsi_panel.c file
mdss_dsi_panel_bklt_pwm() Funtion is running.

However, it does not check the pulse in mpp4

I don’t know what else to do.

Thanks


#4

hi qqhrqqhr2,

To debug this issue further, could you please share the kernel panel dtsi file along with mdss dtsi file.

also please share the kernel logs,

Thanks
Ramesh


#5

Thank you for your answer. It was a hardware problem.