Android ADB: Device not found


#1

Hello there,
I have a Dragonboard 410c with Android OS installed (downloaded from this website).

When I connected the board to a host PC with Ubuntu installed in it (with adb and fastboot installed) and typed “ADB devices” command, I can’t find the Dragonboard device, and the list is empty.

I tried with DIP switch 3 both on and off, but it’s still the same issue.
Am I missing something? What else should I do to make it work?

Thanks in advance.


#2

HI danielya,

Could you provide the ubuntu dmesg command logs (before capturing logs connect and remove the board to ubuntu PC)?
SO that we can check whether ubuntu has detected the board or not


#3

Hi Ramesh,
You were right, according to the dmseg log, the ubuntu PC doesn’t recognize the device.

what should I do?


#4

Power supply is there in the board ??

If yes ,how did you verify ??

If power supply is there in board, led light will blink in yellow color


#5

the LED is green, steady. not yellow


#6

Ensure switch S6 is set to the factory default (0-0-0-0, i.e. all switches are off – see picture url which has given below ). Switch S6 can be found on the reverse side of the board in the bottom right-hand corner.

https://www.96boards.org/wp-content/uploads/2015/04/dip_blue_20150611_142555-300x205.jpg


#7

That was the set of the S6 in the first place.
I know that the board has power because I connected it to a screen and see the display.

Only when I connect it to a PC (tried both linux and windows) the device isn’t recognized. Why?
Thanks.


#8

If you connect mouse or keyboard to the dragonboard ,mini usb will not work. remove mouse or keyboard from board and connect mini usb and try …


#9

I tried it now, only with hdmi monitor connected. Still doesn’t work…
I also tried to turn the board in fastboot mode (by holding S4 while power on) but it still didn’t work…


#10

Can try it on Windows PC.(Instead of ubuntu)


#11

I did. same thing


#12

I am having the same issue with a Windows PC.
Did you manage to solve this issue?


#13

@chrishanf Did you add the lines in the ADB driver’s INF file (android_winusb.inf) from the Dragonboard Android User Guide here (under Additional Information at the bottom, pages 15/16/17 in the manual)?

Had the exact same issue and it did the trick for me, not easy to find the solution though.


#14

Hi

I uploaded the adb USB driver for DragonBoard 410C.

adb usb driver windows DB410C

I hope this solves the problem.


#15

Hi,

I uploaded the instruction.

step-by-step-instruction-to-install-adb-usb-driver-on-windows


#16

Hi guys, thanks for the reply, it worked for me this time :slight_smile:
I copied across the Qalcom data back into the android_winusb.inf file again from the start and it worked. I might have missed something…Previously i got to the step where you open device manager and right click to update the device software. I never got the windows security warning screen before when i browsed and selected the folder with the inf file, but this time i did get it. If people are having this issue, i recommend getting a fresh copy of the *.inf file or undo the changes you made and start the process again.


#17

Hi @chrishanf,

Happy to know my drive and the instruction worked for you on Windows.
:slight_smile:


#18

Hi ,

I prepared the uSD card from the below link and flashed the android OS.

In order to make sure android is up and running , I connected the HDMI cable and able to see the android.
When I connect the dragon 410 C board to Ubuntu( 17.10) not able to see any updates in dmesg and no LED light glowing.

It will be great if somebody help me in establishing adb connection for the dragon board with ubuntu machine?


#19

is there permission issues with USB dev node ?
what is the output when you type sudo adb devices?


#20

c_snarra ,

I am able to detect the board in the other machine as “adb”.
May be the issue with the particular machine.

Thanks for the support