All Vulkan content I've tried fails with SIGSEGV on HiKey960 AOSP 2017.10.23


#1

HiKey960, exact example compilation detailed at: https://github.com/SaschaWillems/Vulkan/issues/389 just flashed AOSP 2017.10.23.

Someone has gotten it to work at: https://www.youtube.com/watch?v=O8lB1Uwi0tw but I couldn’t


#2

what build of aosp are you using and have you tried compiling it from the latest source?
EDIT: just saw you mentioned the build, let me check. It should work out of the box now. In the mean time can you follow this: https://www.96boards.org/blog/vulkan-hikey960/


#3

hmmm… looks like the recent builds haven’t been updated yet. you can build aosp from source https://source.android.com/source/devices

or follow the blog post linked in the previous reply


#4

Thanks Sahaj, I look forward to seeing future builds with Vulkan included by default, many devs might be interested in playing with this hot new API :slight_smile:


#5

Hi, I found a similar problem. The SEGV I am getting is an ASSERT in the tutorial code due to “gpu_count == 0”.

I wrote a dummy test app which just initializes Vulkan and tries to get the physical device count (if it can find an devices it reports their characteristics).

I followed instruction set ‘2’ from here All Vulkan content I’ve tried fails with SIGSEGV on HiKey960 AOSP 2017.10.23 but with no luck

I noticed that this program only works when I rooted the device(!). My conclusion is that the latest AOSP binaries are Android PI and the file /vendor/lib(64)?/hw/vulkan.hikey960.so is not in the /vendor/etc/selinux/vendor_file_contexts. My attempts to add this have so far failed so I’m going to have to build from AOSP source. I have had problems with that recently so I going to try again and hope they are fixed (or just fix them).

Anyway… onwards and upwards.