AiStarVision MIPI Adaptor V2.0 + OV5645 Issues

mezzanine

#1

Hello Everyone,
I seem to be having quite a hard time getting output from an OV5645 camera using the AiStarVision MIPI Adapter V2.0.

So far I’ve tried the following:

Rebuild the 16.09 kernel with the updated apq8016-sbc.dtsi file obtained from here.

Using the following media-ctl pipeline I configured the link between msm_csiphy0 and msm_csid0, msm_csid0 and msm_ispif0.
sudo media-ctl -v -d /dev/media1 -l '"msm_csiphy0":1->"msm_csid0":0[1],"msm_csid0":1->"msm_ispif0":0[1]'

The second pipeline configures the UYVY2X8/1920x1080 format for msm_csiphy0 and msm_csid0. Note that my board now reports that the OV5645’s CCI is on 1-0076 rather than 1-0078.
sudo media-ctl -v -d /dev/media1 -V '"ov5645 1-0076":0[fmt:UYVY2X8/1920x1080],"msm_csiphy0":0[fmt:UYVY2X8/1920x1080],"msm_csid0":0[fmt:UYVY2X8/1920x1080]'

Following the example from the debian 16.06 release I used gstreamer to generate a single JPEG:
gst-launch-1.0 v4l2src device=/dev/video0 num-buffers=1 ! 'video/x-raw,format=UYVY,width=1920,height=1080,framerate=30/1' ! jpegenc ! filesink location=image01.jpg

Running gstreamer at this point either hangs at playback of the source or causes a panic.

I’ve posted the tail of my kernel log after running the gstreamer pipeline on hastebin here.

Any help is appreciated.


#2

Hello Rob_Gries,

Using media-ctl you have to enable link from msm_ispif0 to msm_vfe0_rdi0 too. Then with the second command do not forget to set format on msm_ispif0 and msm_vfe0_rdi0 too. You can check the exact commands on http://builds.96boards.org/releases/dragonboard410c/linaro/debian/latest/
You are welcome to report back your progress.

Best regards,
Todor Tomov


#3

Thanks Todor!

Using these two pipelines:
sudo media-ctl -v -d /dev/media1 -l ‘“msm_csiphy0”:1->“msm_csid0”:0[1],“msm_csid0”:1->“msm_ispif0”:0[1]’,“msm_ispif0”:1->“msm_vfe0_rdi0”:0[1]’

sudo media-ctl -v -d /dev/media1 -V ‘“ov5645 1-0076”:0[fmt:UYVY2X8/1920x1080],“msm_csiphy0”:0[fmt:UYVY2X8/1920x1080],“msm_csid0”:0[fmt:UYVY2X8/1920x1080],“msm_vfe0_rdi0”:0[fmt:UYVY2X8/1920x1080], “msm_ispif0”:0[fmt:UYVY2X8/1920x1080]’

I can now grab frames from the camera using the gstreamer pipeline.

EDIT: Make sure to read the 16.09 release notes, and not the 16.06 release notes I was reading


#4

Good to hear that it worked :slight_smile:

Where do you read the release notes? I think they are up-to-date on: http://builds.96boards.org/releases/dragonboard410c/linaro/debian/latest/


#5

I was reading the 16.06 notes, sorry about the mixup.

https://builds.96boards.org/releases/dragonboard410c/linaro/debian/16.06/