After Debian SD-boot no more eMMC to Stock Android boot possible - HDMI via convertor to VGA issue

I am playing around with my new Dragonboard 410C.
Android was standard installed on eMMC and was booting fine.
I installed latest Debian image to a SD for Boot from SD and switched the small dip on the back, worked fine, got updated by me, wifi worked etc.
Took out SD, switched back dipswitch to all 0 (default position)
Power on -> led 4 blinks for about 20 seconds as if looking for the SD card and then switches off. Nothing else happens. Tried varies times, with and without SD card in the slot. No eMMC boot is happening.
Reinstalled SD card, switched back to Boot from SD and Debian works fine as before.

How do I get back to the eMMC boot with Android?

<<< solved >>>

The issue turns out to be different. Led4 blinks showing device is booting when in Android.
But my HAMA HDMI to VGA convertor + simple old screen attached are not able to show the Android generated video signal. So when I connected to a “real” HDMI monitor all worked fine.

+----------------------+----------------------+--------------------------+
| User LED 4           | Boot                 | This LED illuminates at  |
|                      |                      | at the start of boot     |
|                      |                      | and turns of after       |
|                      |                      | completion of boot.      |
+----------------------+----------------------+--------------------------+