About Board Recovery


#1

I am trying to install the latest debian on my hikey board. Before flashing debian, board recovery is required, I followed the official instructions (https://www.96boards.org/documentation/consumer/hikey/hikey620/installation/board-recovery.md.html).

After that, when keeping the Link 1-2 and 5-6 closed , the command “sudo fastboot devices” can not find any device. Is there anything wrong?


#2

It is possible the board is broken.

However before deciding that it would be good to know whether your board is a circuitco hikey (4G eMMC) or lemaker hikey (8G) version.

It would also be good to share the terminal output during your recovery attempt so we can see the output of all the command when you run hisi-idt.py and fastboot (copying it into a pastebin or github gist and then posting a link works well for sharing logs).

Finally, do you have a 1.8v serial adapter… the best place to get clues about what might be happening to the board is to look at the serial logs.


#3

@danielt
Thank you.

I tried the instructions with three hikey boards and got the same outputs. The boards are lemaker hikey (8G) version.

I have submitted an issue with detailed logs at github (https://github.com/96boards/documentation/issues/600). The maintainer closed the issue and suggested me to put my question here.

I do not have a serial adapter, there are just commands and the corresponding outputs in the issue.

Besides, I successfully flashed android and debian jessie (http://releases.linaro.org/96boards/archive/reference-platform/debian/hikey/16.06/) to the same hikey boards. I also tried to combine the bootloader contained in aosp factory image, with the boot image & rootfs of debian stretch. The system could boot up. But there are some errors with the NIC which said “wlcore: ERROR firmware boot failed despite 3 retries”.

I’d to run debian stretch on my hikey boards, and the network card should perform well. Any suggestions?

Thanks.


#4

Shame… that’s probably the best way to figure out what might be happening here.

AFAIK pretty much all the drivers for hikey have been upstreamed at this point which means the distros are starting to support it out of the box. For example the interested parties at Debian keep up a wiki describing how to install: https://wiki.debian.org/InstallingDebianOn/96Boards/HiKey

(don’t know if WiFi will work though… it’s an off-chip device on Hikey)


#5

Almost all the links in the Debian Wiki page are obsolete. I use the files on this page (http://releases.linaro.org/96boards/archive/reference-platform/debian/hikey/16.06/) instead. The system can not up.

I have tried the official instructions for recovery with 3 boards and almost all the versions of the binary files in
the website (https://snapshots.linaro.org/96boards//reference-platform/components/uefi-staging/), but I did not get a satisfying result.

Since I can flash Aosp image and previous Debian images into the boards, so I think my boards perform well. I wonder if there is anything wrong with instructions or the binary files.

Thanks.


#6

I usually use below debian images on my Hikey and Hikey960 boards, the images can work well on both these two boards:

https://snapshots.linaro.org/96boards//hikey/linaro/debian/latest/


#7

Oops, thanks for reporting the failure. I can confirm the latest snapshot building for boot images are broken on Hikey board: https://bugs.96boards.org/show_bug.cgi?id=782

As you have tried to use AOSP booting images, or you could roll back to use the older one booting images: https://snapshots.linaro.org/96boards/reference-platform/components/uefi-staging/76/hikey/debug/.


#8

@leo-yan @danielt

Problem solved.

Thanks!