80211n on dragonboard-410c


Is anyone else seeing
deauthenticated from xx:xx:xx:xx:xx:xx (Reason: 34=DISASSOC_LOW_ACK) and / or
deauthenticated from xx:xx:xx:xx:xx:xx (Reason: 6=CLASS2_FRAME_FROM_NONAUTH_STA)
on dragonboard410c? I am using yocto zeus with meta-qcom, and dragonboard-410c-bootloader-emmc-linux-137.

It is reproducible if I run iperf for like 600 seconds. Once, the driver gets into this stage, I loops with connects and disconnects, it is difficult to get a usable connection once in this stage. I do not see it with a non 80211n AP. I tried with iwd 1.7 and wpa_supplicant 2.9, both have the same issues.



can you provide the iperf commands you run on both side for reproduction purpose

I ran
iperf3 -s
on the dragonboard and
iperf3 -c <ipAddressDB> -i 1 -t 600
on the host. I figured it had to do my wifi boxes (Sonos) running at the same time. I wonder how they manage to get the DB kicked out of the wifi…

OK I don’t meet this issue on my side and get about 48 Mbits/sec in throughput. Does the Sonos also act as a WiFi AP (for other sonos elements), if yes, could you double check it does not use the same channel as your WiFi AP/router (or an adjacent one).