410c Android - "undefined abort, halting"


#1

Hi,

I tried installing Android on my 410c using the instructions in https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android#install-android-or-ubuntu-using-fastboot, but the bootup aborts saying “[480] undefined abort, halting”

Serial console:
[10] platform_init()
[10] target_init()
[40] SDHC Running in HS200 mode
[50] Done initialization of the card
[60] pm8x41_get_is_cold_boot: cold boot
[60] No ‘frp’ partition found
[60] Not able to search the panel:
[70] Display not enabled for 24 HW type
[70] Target panel init not found!
[70] pm8x41_get_is_cold_boot: cold boot
[80] Unable to locate /bootselect partition
[80] use_signed_kernel=0, is_unlocked=0, is_tampered=0.
[90] Loading boot image (16521216): start
[190] Loading boot image (16521216): done
[260] DTB Total entry: 212, DTB version: 3
[260] Using DTB entry 0x000000f7/00000000/0x00000018/0 for device 0x000000f7/000 10000/0x00010018/0
[270] target_display_panel_node:510: hw_id=24 panel_name=""
[270] cmdline: console=ttyHSL0,115200,n8 androidboot.console=ttyHSL0 androidboot .hardware=qcom msm_rtb.filter=0x237 ehci-hcd.park=3 androidboot.bootdevice=78249 00.sdhci lpm_levels.sleep_disabled=1 earlyprintk androidboot.selinux=permissive androidboot.emmc=true[300] Updating device tree: start
[470] Updating device tree: done
[470] booting linux @ 0x80008000, ramdisk @ 0x82000000 (795397), tags/device tre e @ 0x81e00000
[480] undefined abort, halting
[480] r0 0x00000000 r1 0x00000000 r2 0x81e00000 r3 0x644d5241
[480] r4 0x8f685860 r5 0x000c2305 r6 0x82000000 r7 0x8f6901a0
[480] r8 0x81e00000 r9 0x81e00000 r10 0x80008000 r11 0x80008000
[480] r12 0x600001d3 usp 0x00000000 ulr 0x00000000 pc 0x80008000
[480] spsr 0x800001d3


#2

Update: Just as a sanity check, I installed Ubuntu using https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android#install-android-release and I was able to get to the serial Linux console. I downloaded android bootloader & release images once gain and re-flashed (on top of Ubuntu), but I get the same error.


#3

[SOLVED] I had to use images from http://builds.96boards.org/releases/dragonboard410c/qualcomm/android/15.06/ as against http://builds.96boards.org/releases/dragonboard410c/qualcomm/android/latest/ to get Android up and running.