12V or 1 V


#1

Setting:
I am measuring the power consumption of the entire board by using a INA219 in the main power line from adapter (before DC jack). I attached a 5V UART to the board using a 69Linker mezzanine board which is connected to the ‘low speed expansion connector’(to convert 5v to 3.3v).

Observation:
when I measure the power while the UART cable is attached to the board, I read 12V, and 140 mA from INA219.
However, when I detach the UART cable, I read 1V, and almost the same current(140 mA).

Question:
where this “12v” is coming from? and how I can calculate the power? should I multiply 12v * 140mA, or multiply 1v * 140mA?

Thanks :slight_smile:


#2

Hi @amati,

May I try to repeat to understand your configuration of the hardware?

The DragoneBoard only has the Linker mezzanine board and nothing else is connected on DragonBoard.
Connecting 5V UART to the the Linker mezzanine board.
The INA219 is connect before the DC Jack of the DragoneBoard.
Measuring the voltage and the current on INA219 for the entire DragoneBoard with the Linker mezzanine board.

Do you mind teaching how are your reading the value from INA219?
What is 5V UART connected to the Linker mezzanine board used for?


#3

.


#4

Hi

for reading from INA219, I used Aurdino Uno: https://learn.adafruit.com/adafruit-ina219-current-sensor-breakout/wiring

the dragonboard requires a UART with 3.3 v, but I had a 5 V Uart, hence I used Linker as a voltage shifter.

I tried to follow the instructions in the following document, but with a little modification based on what I had:


#5

This sounds like a grounding issue. The INA219 measures current across the 0.1 Ohm current sense resistor on the board. The INA219 measures voltage between the current sense resistor and the ‘ground’ point on the board.

I believe that you have the INA219 data connections to one computer, and the current sense connection to the 410c. Is this correct? When you connect the USB cable, then the ground point on the 410c is tied to the ground point on your host computer (through the USB cable) and all works as expected. When you disconnect the USB cable, the 410c, and your host computer have independent grounds, hence the voltage does not read correctly. You need to add a ground jumper from the 410c, to the INA219 board.

Take a look at this app note: https://developer.qualcomm.com/download/db410c/power-measurement-appnote.pdf

Full Disclosure: I am an employee of Qualcomm Canada, any opinions expressed in this or any other post may not reflect the opinions of my employer.


#6

Thanks for your reply. yes, I am reading from INA219 by a Aurdino Uno which is connected by a usb cable to my pc.

my base configuration:
I connected the INA 219 to the Aurdino like this:
vcc(INA) -> 3.3 pin(aurdinu, power)
GND(INA) -> GND pin(aurdinu, power)
scl(INA) -> A5 (aurdinu, Analog in)
sda(INA) -> A4 (aurdinu, Analog in)
Vin- and Vin+ are not connected.

I connected the UART to the Linker like this:
blk(UART) -> GND(UART section of Linker)
Green(UART) -> SCL(UART section of Linker)
white(UART) -> SDA(UART section of Linker)

==================================================
do the Linker Mezannine and DB share the same GND?
which port on Linker should I connect to the Aurdino?

I tried this configurations:
1- the second GND of aurdino -> GND (JP10 ,Linker) => result: still read 12v
2- Vin- of INA219 -> GND (JP10 ,Linker) => result: read 0V, UART does not work anymore


#7

Hi @amati,

The UART seem to be playing a key roll here.

I am still bit confused about the your UART usage.
Are you using the UART to see the serial console screen from the DragonBoard 410C?
Or some other usage.

I do not see using UART in the documentation you referring to.

The UART port on the Linker Mezzanine is connected to UART3 on the LS connector from 96boards, which is not able to use for seeing the serial console screen, with such as minicom.


#8

Hi @amati,

There are description on the quick link on this forum for using the serial console on 96Boards.

Short intro to start your DragonBoard 410C with serial console


#9

Hi @amati,

The Correct voltage reading should be 12V (not 1V). When you connect the ground of the Arduino to the ground on the Mezzanine board, you get the correct reading. When you connect the Vcc on the INA219 to ground on the INA219 you have shorted out the power supply, and as expected it doesn’t work with no power.

The Vin+ and Vin- terminals on the INA219 ARE NOT “power” and “ground”. Vin+ should be connected to your power supply (positive), and Vin- should be connected to the load (the center pin on the 410c power connector). The “current” flowing from Vin+ to Vin- is measured by the INA219, The INA219 also measures the “voltage” between Vin- and the Gnd pin on the INA219 board. You need to connect the Gnd pin on the INA219 board to GND somewhere on the 410c or the mezzanine board. You also need to connect the Gnd pin on the INA219 to Ground on the Arduino, Note: two ground wires.

When you connected the UART adapter to the 410c, and you connected the Arduino to your host computer, you effectively connected the ground on the 410c to GND on the INA219 (the second GND wire). The ground path was from the 410c, through the UART adapter, to the host computer, then from the host computer through the USB cable, to the Arduino, then from the Arduino to the INA219 through the wiring from the Arduino to the INA219. This is a really complex connection but it works. When you disconnected the UART adapter you broke the ground connection and hence you read only 1V at the INA219. This is why you need the second ground wire from the INA219 to the 410c.

The INA219 computes the Power by multiplying voltage (in volts) by current (in Amps) the get the total power consumption (in Watts).

Full Disclosure: I am an employee of Qualcomm Canada, any opinions expressed in this or any other post may not reflect the opinions of my employer.


#10

Hi
I got a terminal(serial console) from the DB using the UART connected to the Linker Mezannine, and I am using it. this is my first time using serial console, but I think that the console that I have is behaving normal.

thanks.


#11

thanks for your very informative comment. you are right: when I disconnect the UART, and share the ground of INA219, DB, and Aurdino, I will get 12v again.
do you have any idea about the power consumption of DB? I get around 100mA and 1200mw without attaching any peripherals(i.e. mouse, keyboard, screen). I am using Linux. wifi is on. and I dont know about the status of GPS.
Thanks for you help.


#12

Hi @amati,

Thank you for your reply.

I learned my misunderstanding from you. :slight_smile:

The UART port on the Linker Mezannine is able to see the serial console screen,
since it is connected to pin 11 and 13 on the LS connector.

I was misunderstanding just because I blindly thought the naming on the 96Boards specification of pin11/13 is “UART1” and thought which is different from “UART3” printed on the Linker Mezzanine.

I do not have 5.5v UART adapter on my hand and I would like to try it.

blk(UART) -> pin 1, GND(UART port of Linker)
TXD(UART) -> pin 4, RX (UART port of Linker)
RXD(UART) -> pin 3, TX (UART port of Linker)


#13

I tried to do that. Boom! I mistakenly connected the VCC of Linker to GND of UART, and I lost my UART. I have to order another one. I wish my Linker being safe.

Ahmad


#14

Hi @amati,

I tried using serial console on the the UART port on the Linker Mezzanine.

It worked without any problem.

This is my screen of the serial console.


<5>[    0.000000] Linux version 3.10.49-g0b014e2-00006-g1982baf (buildslave@aos6
<4>[    0.000000] CPU: AArch64 Processor [410fd030] revision 0
<6>[    0.000000] Machine: Qualcomm Technologies, Inc. APQ 8016 SBC

I bought the 5.5V USB UART, FTDI TTL-232R-5V-WE.

This was my connection.
I set the JP9 on the Linker Mezzanine to 5V.

GND(UART)black -> pin 1, GND(UART port of Linker)
TXD(UART)orenge -> pin 4, RX (UART port of Linker)
RXD(UART)yellow -> pin 3, TX (UART port of Linker)