1080p video with Win10 IoT Core


#1

Hi,

Is it possible to get a DragonBoard 410c running Win10 IoT Core to display 1080p video? Out of the box, IoT Core on this device displays 1280x720, and changing this resolution is impossible.

I’m able to generate my own OS images, so I can include anything I need to enable 1920x1080 output, and I’m under the impression that something from Qualcomm is required to get this video mode enabled. I don’t have that piece and I don’t know where to get it.

Does anyone know how I can approach this?

Thanks!


#2

Hi @naikrovek

You could always take a look at the Win10 Display Drivers Guide here: https://developer.qualcomm.com/download/sd410/display-drivers-config-guide-windows10-iot.pdf It does discuss enabling 1080p video output in section D.

I am not a Win10 developer so I am not familiar with the tools and prerequisites you will need in order to make the recommended changes, but it should at least give you an idea of where to start.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#3

Thank you. I tried that previously and it had no effect whatsoever. I am not sure if the step worked or if there are other steps I need to take, or both. Or neither.

There’s a wide gap here. Microsoft points people here for support with the DB410c and the number of Windows people here is very close to zero.


#4

Hi naikrovek,

As mentioned in D Enabling 1080p video output (lm80-p0337-1_a_display_drivers_acpi_and_xml)
Copy the following file into a Notepad and rename the file to panelcfg.xml first before copying to the SD card:
panelcfg.xml needs to copied over to root of FAT32 formatted SD card and inserted into SD card slot of the 8016 IOT device (please use the file as is, and do not rename it)
Reboot the device for changes to take place

Note:The panelcfg.xml file with sd card needs to be inserted all the time, between reboots. If you do not insert the SD card during a bootup it will bootup with default config(HDMI 720p)
To revert the display back to HDMI, just remove the sdcard that has the dsi panelcfg.xml. Device will enable hdmi display on next boot.


410c Windows 10 IoT - Screen Resolution
#5

Thank you. I will attempt this soon.


#6

Holy schnikeys, it worked. It fooled me at first, though, and I thought it wasn’t working because it applies display scaling and all the screen elements are the same size on screen as they are at 1280x720.

@MahenderReddy Thank you very much. Time to buy more MicroSD cards.


#7

I successfully did it for a 1080p resolution. (the pdf file guide: lm80-p0337-1_a_display_drivers_acpi_and_xml.pdf) But… Did someone actually try to use this method to run a 7-inch touch screen on the DragonBoard 410C? In the xml file I tried to change the 1280 and 720 with the resolution that I want, but with no success. (I tried the 1024x600 resolution, but screen doesn’t work.) I suppose I have to change more things in order to get it work.

<HorizontalActive units='Dot Clocks'>1280</HorizontalActive>
<VerticalActive units='Dot Clocks'>720</VerticalActive>

Would someone with more knowledge help me? I’ll appreciate any help.
Thanks in advance. :slight_smile:


#8

HI miroslav.chakarov,

Are you trying with this panel https://www.arrow.com/en/products/96boards-display-7/linksprite-technologies-inc ?
if not please share which panel are you using ? Please let me know what is the resolution you modified ?

Thanks
Ramesh


#9

Is it possible, to disable the DPI scaling? According to my readings in my UWP app, it is set to 150%, when Setting the resolution to 1080p with the XML file. If i could get the DPI scaling back to 100%, then i’m perfectly happy with the dragonboard, but at the moment, it is unusable for my project. I need 1080p resolution combined with normal (100%) DPI scaling.


#10

Hi, Ramesh!
Thank you for your reply.

I’m using a very similar panel like that you shared. It’s the WaveShare 7-inch screen with 1024x600 resolution:
https://www.waveshare.com/7inch-hdmi-lcd-c.htm ,
but the resolution is different.
On a standard screen I can make it run the 1080p screen resolution as the Qualcomm guide says.
But on this small screen I can’t make it work on its 1024x600 resolution.
I’ll be very glad if you can help me!

Thanks in advance.


#11

@miroslav.chakarov

You wrote that you can run the 1080p screen resolution on a standard screen, did you build a new Image (BSP) for that?


#12

Hi, Andy.
No, I didn’t. I just have followed the Qualcomm’s PDF guide:


Page 79 explains how to enable 1080p.

You just have to copy the XML code to a file and put it into the root directory of an SD card. The file must have a name “panelcfg.xml”, or otherwise it won’t work.
Then boot the DragonBoard with the SD card inserted.

And you’re done.


#13

@miroslav.chakarov

Thank you for your answer. I made this already, but then the DPI in Windows 10 IoT Core is set to 150%, so everything has the same size, as it have with 720p resolution, that is my main problem. Is this also the case for you?


#14

@andy66
Yes, that’s the case. It’s like you’re still on 720p, but if you look closely, it’s 1080p.
Unfortunately I don’t know how to fix the DPI Scaling.

But my main problem is to make the DragonBoard run on other resolutions, no matter what’s the DPI.
I hope @ramesh-bura can help me.

Regards.


#15

@miroslav.chakarov

The DPI scaling is a real issue for me, because with this scaling i have to set the text and other UI controls much smaller, to fit my needs, but the downside of this is that everything is not as crisp sharp anymore.
Inside the BSP sources i saw that there are other resolutions, which should be able to drive with the DB, but for this to work, it seems that there is no way around building a new BSP and Windows IoT Core image.

I really hope, that there is someone out there who has experience with that process and like to share the steps with us.


#16

Finally, with the october update (build 10.0.17763.1) 1080p works for me. But sadly, MS did not use the current BSP from Qualcomm, but that’s another Story.

Edit// As it turns out, MS is using the latest BSP in their october update :slight_smile: