[Yocto] Not able to login


#1

Hello all,

I succesfully and easily build my yocto image (rpb-console-image) under krogoth distrib.
I also succesfully created my bootable sd card thanks to the tuto : https://github.com/96boards/documentation/wiki/Dragonboard-410c-GPT .
My problem is when the login prompt, i’m not able to go through. I tried (root, “”) and (linaro, “”) but none of them worked. I also checked the /etc/password and /etc/shadow of my rootfs and everything looks right.

May I have miss something ?

Next hint would be to add “debug-tweaks” to EXTRA_IMAGE_FEATURES…

Thanks,

Jérôme.


#2

Have you tried (linaro, linaro)?


#3

Yes I did too


#4

Not too familiar with oe but https://github.com/96boards/meta-rpb/blob/master/recipes-samples/images/rpb-console-image.bb#L26 seems to indicate the (linaro,"") is right. Do you have something like below under /etc/shadow?


linaro::17039:0:99999:7:::


#5

I do not build krogoth branch, but I verify rpb-desktop-image on 16.06 release (it’s under jethro branch) and it works for me.


#6

Yes this is what I have in /etc/shadow.
By any chance do could you reproduce my problem with a bootable SD? That may prove that I did something wrong or not.
I’m also wondering if it is not because I try to boot from the SD.


#7

Thanks Daniel for the feedback, I will try with the tag 16.06 then.


#8

@jtis Sorry. I’m not aware that you are running with bootable sd card. The post I mentioned is booted from eMMC. Are you also OK on booting from eMMC?


#9

I haven’t tried yet to flash the emmc with the Yocto distrib. I was looking how to fastboot the created rootfs .ext4 I got an sparse error when I try to do : fastboot flash rootfs *rootfs.ext4


#10

It should be OK. Make sure you can see fastboot device first!
You may see the device like this.

$ fastboot device
c3d02320        fastboot

#11

hi, what is the error with ‘fastboot flash’? can you share the command output?

currently we still have a limitation that the rootfs image generated by OE is not a sparse image. it is an ext4 image (it can be loop mounted, for example). we are currently adding the support for the sparse image generation tool, so that the output image will be automatically sparsed.

however you can sparse the image after the build and before flashing it with

ext2simg <rootfs>.ext4 <rootfs>.img

ext2simg is available in Debian/Ubuntu in android-tools-fsutils package.


#12

Yes I guess this is the step I missed before “flasboot flashing” it.
I will give a try tonight and keep you posted.


#13

Ok so I finally flashed the emmc with the image I used at the beginning of this post and this seems to solved my problem.
Unfortunatly I don’t have much time to do more tests to understand why this happened but so far I would point out the SD card and its flash method.


#14

i tried today, and I am able to boot from SD card and login properly… I have followed the same instructions as per the wiki. I can login with ‘root’ and with ‘linaro’.

i suspect something has gone wrong on your side, likely when you copy the rootfs onto the SD card. How did you do that?


#15

Thanks for that.
I will try to do the manip one more time tonight. Indeed maybe something goes wrong with the SD flashing.
I “dd” the rootfs like told in the tuto. Did you used the boot.img and the rootfs.ext4 generated by a fresh krogoth compilation ? Or did you take the one from the 96board ftp?
I’m still surprise that the boot.img is not regenerated after each new bitbake (even if I slightly change the kernel).


#16

I used an image that I built. It’s based on the krogoth manifest branch (as of yesterday).

the boot image not being regenerated would be a problem indeed. I am sorry if you already mentioned that in the past… i have missed it. What’s the issue again?


#17

No you haven’t missed it I just noticed it from the last few days because I’m building yocto again and again ^^.
I certainly missed something. Because I tried to customized the kernel and add some options.
What I tried is :
1/Changed the defconfig by bitbake -c menuconfig
2/Add the modules I need in meta-qcom/recipes-kernel/linux/linux-linaro-lt-freedreno/defconfig and also in ${S}/arch/arm64/configs/defconfig

I know it is bit rude and probably not the good way but I was expecting a new boot.img with my modules.


#18

@ndec,

Ok so I have done many test and the result is that I finally giveup on the old method (the one that need too dd on the sdcard) and I pull the last modification you have done in db-boot-tools (really useful when everything is setup).

I finally understand that the problem came from the formating (I haven’t check if with the old method it was cut in 10parts) but the following command line in the tuto need to be changed :
1/ "abootimg -u boot-XXX.img -c “cmdline=root=/dev/mmcblk1p9p10 rw rootwait console=ttyMSM0,115200n8”

With the new feature in db-boot-tools you also need to review the tutorial on “sudo ./mksdcard.sh …” because the folder changed and you don’t have the choice to provide the rootfs and the boot now (I don’t know if it could matter or not)

Also I had to modify “db-boot-tools/dragonboard410c/linux/partitions.txt” line rootfs “rootfs,1024000,fastboot,rootfs.img” I fixed the flashed size at 1Go because when flashing the card it gave the error “error: file_write: write: No space left on device”

After what I successfully booted and logged on the SD card.

Jérôme.


#19

Hi ndec,

i am using r1033.1 release, with IMM.LE.1.0-28000-8x16.0 tag.
I am using open-embedded build system, i have clone the source and compiled it.

After compilation i found the compiled image i.e boot.img and rootfs.ext4 are not sparse image.Here you have mention that you are working on that i.e adding support of the sparse image generation and we will get directly sparse image after compilation.

Is this support is added in any release ? Can you please provide some more information on that ?

PS: I am able to generate sparse image of rootfs.ext4 using ext2simg tool but facing issue to generate sparse image of boot.img.

Regards,
Keval


#20

That doesn’t look like one of the 96Boards releases. Our releases usually use YYYY.MM[.PL] such as 2017.04 or 2017.06.01 format and are found here:
http://builds.96boards.org/releases/dragonboard410c/linaro/openembedded/17.06.1/ (binaries and release notes)
https://github.com/Linaro/documentation/blob/master/Reference-Platform/CECommon/OE.md (additional docs)

Having said the above, the 96Boards releases also do not use libsparse format either, fastboot should normally handle raw images that transparently (if not try getting an updated version) as shown in the documentation.

However if you really do want to use libsparse format you can use img2simg for non-filesystem images (like boot) and ext2simg for ext2/3/4 filesystem images.