Yocto build


#1

Hello,
The last version the Yocto bitbake exits with the following error:
ERROR: Nothing RPROVIDES 'networkmanager-nmtui’
Is there something missing in the meta-rpb?
Thank you, Leonid.


#2

Can you please share the entire log so that we can see all layers/versions you are using?

Thanks


#3

Hello,
The full log is accessible here: http://pastebin.com/j5GB3XfC
The repo manifest -r output is:

<?xml version=“1.0” encoding=“UTF-8”?>
<manifest>
<remote fetch=“https://bitbucket.org” name=“bitbucket”/>
<remote fetch=“https://github.com” name=“github”/>
<remote fetch=“http://git.linaro.org” name=“linaro”/>
<remote fetch=“git://git.openembedded.org” name=“oe”/>
<remote fetch=“http://git.shr-project.org” name=“shr”/>
<remote fetch=“http://git.yoctoproject.org” name=“yocto”/>

<default revision=“jethro” sync-j=“4”/>

<project name=“96boards/meta-96boards” path=“layers/meta-96boards” remote=“github” revision=“34ea60db158393104cbeb7d3c63bedf3dea14e39” upstream=“master”/>
<project name=“96boards/meta-rpb” path=“layers/meta-rpb” remote=“github” revision=“8691e5b257386e0e4d491e22c57b6f58cd0dd83f” upstream=“master”/>
<project name=“OSSystems/meta-browser” path=“layers/meta-browser” remote=“github” revision=“e114d625d4bd23a52cc1108a45d96ffd8dc0ab7f” upstream=“jethro”/>
<project name=“meta-qt5/meta-qt5” path=“layers/meta-qt5” remote=“github” revision=“ea37a0bc987aa9484937ad68f762b4657c198617” upstream=“jethro”/>
<project name=“ndechesne/meta-qcom” path=“layers/meta-qcom” remote=“github” revision=“2bf741274e1d106f68ffecbf0d9d91c3bdadeab0” upstream=“jethro”>
<linkfile dest=“setup-environment” src="…/…/.repo/manifests/setup-environment"/>
</project>
<project name=“openembedded/bitbake” path=“bitbake” remote=“github” revision=“0e9d8d63ddb35d181d4e470585d1e4a4c646cd00” upstream=“1.28”/>
<project name=“openembedded/meta-backports” path=“layers/meta-backports” remote=“linaro” revision=“7630f48291f397c064ff4b2a7c67215e0700f11d” upstream=“jethro”
<project name=“openembedded/meta-linaro” path=“layers/meta-linaro” remote=“linaro” revision=“9b1fd178309544dff1f7453e796a9437125bc0d9” upstream=“jethro”/>
<project name=“openembedded/meta-openembedded” path=“layers/meta-openembedded” remote=“github” revision=“8ab04afbffb4bc5184cfe0655049de6f44269990” upstream="j
<project name=“openembedded/openembedded-core” path=“layers/openembedded-core” remote=“github” revision=“f6999fa952c7db980cfc97f6e5a971e4f34cc0a3” upstream="j
</manifest>

The problem is in the meta-rpb manifest
Thank you, Leonid.


#4

argh… good catch… we switch from connman to networkmanager in meta-rpb, but didn’t realize that jethro doesn’t have nmtui…

in the mean time, you can remove networkmanager-nmtui manually from the image recipe, i will check how to fix that properly. either we can enable nmtui in jethro, or we will revert this change for jethro and use networkmanager only in krogoth and above.

by the way, you are sticking to jethro for any specific reason? we have switch our default builds to the krogoth branch since a couple of months (Note that this is not an excuse for this issue, of course)…


#5

Hello,
Ok, I will fix it locally.
I am trying to stick to the latest version available here on the forum,
the last one I can find is:
http://www.96boards.org/forums/topic/16-06-linux-release-for-dragonboard-410c/
And the link to Yocto project is:

Can you please share the link to krogoth release?
Thank you, Leonid.


#6

Hi,

I would say here : https://github.com/96boards/oe-rpb-manifest

Jérôme.


#7

Thank you very much.


#8

Hi Leonid,

thanks for reporting the problem. It should be fixed now, after you update your working tree with ‘repo sync’. The fix is this patch: https://git.linaro.org/openembedded/meta-backports.git/commit/afdcaa69a314df6586fca149a5f0fc85f52fc233

You should be able to switch to krogoth with

repo init -b krogoth
repo sync

Or alternatively create a new repo workspace.