Writing GPT failed on installing boot image for TB-96AIoT


I tried to install boot image to TB-96AIoT with Ubuntu18.04 PC according to installation guide, but failed.

Installation steps is as below:

$ ls
Linux_Upgrade_Tool_v1.38/  Linux_Upgrade_Tool_v1.38.zip  TB-96AIoT-images-npu1.3.2-20200923.rar  TB-96AIoT_img_20190528.rar
$ rm -fr Linux_Upgrade_Tool_v1.38
$ unzip Linux_Upgrade_Tool_v1.38.zip 
Archive:  Linux_Upgrade_Tool_v1.38.zip
   creating: Linux_Upgrade_Tool_v1.38/
  inflating: Linux_Upgrade_Tool_v1.38/config.ini  
  inflating: Linux_Upgrade_Tool_v1.38/Linuxソェキ「ケ、セ゚ハケモテハヨイ畧v1.32.pdf  
  inflating: Linux_Upgrade_Tool_v1.38/Readme.txt  
  inflating: Linux_Upgrade_Tool_v1.38/upgrade_tool  
$ cd Linux_Upgrade_Tool_v1.38/
$ ls
Linuxソェキ「ケ、セ゚ハケモテハヨイ畧v1.32.pdf  Readme.txt  config.ini  upgrade_tool
$ unrar x ../TB-96AIoT_img_20190528.rar 

UNRAR 5.50 freeware      Copyright (c) 1993-2017 Alexander Roshal

Extracting from ../TB-96AIoT_img_20190528.rar

Extracting  recovery.img                                              OK 
Extracting  rootfs.ext4                                               OK 
Extracting  rootfs.img                                                OK 
Extracting  trust.img                                                 OK 
Extracting  uboot.img                                                 OK 
Extracting  update.img                                                OK 
Extracting  userdata.img                                              OK 
Extracting  boot.img                                                  OK 
Extracting  MiniLoaderAll.bin                                         OK 
Extracting  misc.img                                                  OK 
Extracting  oem.img                                                   OK 
Extracting  parameter.txt                                             OK 
All OK
$ chmod 700 upgrade_tool 
$ sudo ./upgrade_tool 
Program Data in $HOME/.config/upgrade_tool
List of rockusb connected
DevNo=1	Vid=0x2207,Pid=0x180a,LocationID=109	Mode=Maskrom
Found 1 rockusb,Select input DevNo,Rescan press <R>,Quit press <Q>:1

---------------------Tool Usage ---------------------
Help:             H
Quit:             Q
Version:          V
Clear Screen:     CS
------------------Upgrade Command ------------------
ChooseDevice:		CD
ListDevice:		    LD
SwitchDevice:		SD
UpgradeFirmware:	UF <Firmware> [-noreset]
UpgradeLoader:		UL <Loader> [-noreset]
DownloadImage:		DI <-p|-b|-k|-s|-r|-m|-u|-t|-re image>
DownloadBoot:		DB <Loader>
EraseFlash:		EF <Loader|firmware> [DirectLBA]
PartitionList:		PL
----------------Professional Command -----------------
TestDevice:		TD
ResetDevice:		RD [subcode]
ResetPipe:		RP [pipe]
ReadCapability:		RCB
ReadFlashID:		RID
ReadFlashInfo:		RFI
ReadChipInfo:		RCI
ReadSector:		RS  <BeginSec> <SectorLen> [-decode] [File]
WriteSector:		WS  <BeginSec> <File>
ReadLBA:		RL  <BeginSec> <SectorLen> [File]
WriteLBA:		WL  <BeginSec> <File>
EraseLBA:		EL  <BeginSec> <EraseCount> 
EraseBlock:		EB <CS> <BeginBlock> <BlokcLen> [--Force]

Rockusb>ul MiniLoaderAll.bin
Loading loader...
Support Type:RK180A	Loader ver:1.00	Loader Time:2019-05-22 14:05:07
Upgrade loader ok.
Rockusb>di -p parameter.txt
Write gpt...
Download gpt quit,Creating comm object failed!

Here is the log in $HOME/.config/upgrade_tool/log:

17:28:28 	Current process in /$HOME/ダウンロード/Linux_Upgrade_Tool_v1.38
17:28:28 	Using /$HOME/.config/upgrade_tool/config.ini
17:28:47 	Download Boot Start
17:28:48 	Download Boot Success
17:28:48 	Wait For Maskrom Start
17:28:48 	Wait For Maskrom Success
17:28:48 	Test Device Start
17:28:48 	Test Device Success
17:28:48 	Check Chip Start
17:28:48 	Check Chip Success
17:28:48 	Get FlashInfo Start
17:28:48 	<LAYER 1-9> INFO:FlashInfo: 0 F0 D1 1 0 4 4 0 28 0 1
17:28:48 	Get FlashInfo Success
17:28:48 	 Prepare IDB Start
17:28:48 	<LAYER 1-9> INFO:CS(1)		(14910MB)		(SAMSUNG)
17:28:48 	Prepare IDB Success
17:28:48 	Download IDB Start
17:28:48 	Download IDB Success
17:28:56 	Error:libusb_claim_interface failed,err=-6
17:28:56 	Info:start download,directlba=0,first4access=0,gpt=1
17:28:56 	Error:libusb_claim_interface failed,err=-6

I tried not only TB-96AIoT_img_20190528.rar but also TB-96AIoT-images-npu1.3.2-20200923.rar, but nothing changes.

NOTE: path to home directory is replaced with “$HOME” in the aboves.

I would appreciate if you would help me with installing the image.

Thank you.