Woo to install 32bit chroot environments - any fix?


#1

Hi,

I’m trying to set up a chroot’ed 32bit user environment with debian that is pre-installed on the hikey board.

I ran the following command

sudo debootstrap --arch armhf testing /armhf

It would have the following error (copied from debootstrap.log file)

Failed to generate randomized : Invalid argument
dpkg: error processing package systemd (–install);
subprocess installed post-installation script returned error exit status 1
Processing triggers for lib-bin (2.24-3) …
Errors were encountered while processing:
systemd

Google search does not give much clues. Anybody has any pointers?


#2

Can you try doing it as a two-stage debootstrap? Basically add “–foreign” to the initial debootstrap invocation. That will unpack things (first-stage) but not run all the configuration scripts (second-stage). It might also be good to try using jessie rather than testing until you’ve proven the steps work.

The second stage in then performed from within the chroot:

sudo debootstrap –arch=armhf --foreign jessie /armhf
sudo chroot /armhf
export LANG=C
/debootstrap/debootstrap --second-stage

#3

Thanks, Daniel. The two steps worked.