Windows USB Driver Issue: PID changed


#1

I was wondering if I could get help with an issue I have.

I am working through using the Dragonboard 410c in Android mode with default factory settings with a view to exploring its capabilities before flashing it with Windows 10-IoT Core and making a comparison. My background is the Windows stack top, middle and bottom but mainly the embedded/IoT domain. I have previously worked with Linux and Unix though, but not Android so I have had a learning curve.

I have blogged my experiences at http://embedded101.com/Blogs/David-Jones

Whilst I could download Android apps to the device I couldn’t debug them. They would run there though.
Recently I tried a few things to get debugging working including turning debugging off on the device. I have re-enabled debugged mode on the device using the setting toggle. A strange thing happened, the PID (of VID/PID) changed from 9091 to 9092 ?? I had to reconfigure the driver for the 9092 configuration and reinstall which worked. But now adb does not work.
adb devices says no connected devices as does adb usb

It’s quite strange that he PID changed in this way.
This issue has arisen on two machines. Both originally showed three Android devices, same VID/PID but different M number. One machine now shows only 2 whereas the other shows all three.
I have tried reboots etc.

Note that the Android UI works OK on the device.

Help on this would be much appreciated. I was getting to the end of these “raw” Android musings.
Next I was going to try the Visual Studio 2013 plugin (is there a Visual Studio 2015 version) then try some Xamarin before moving onto Windows 10-IoT Core.

Help on this would be appreciated.

Thx

David Jones
Microsoft WinHEC (fka Embedded) MVP
Sportronics
Australia
http://embedded101.com/Blogs/David-Jones


#2

Hi @djaus,

I saw your blog. Great information of WinCE and Embedded.

The PID changes in Android when services are changed they update PID to ensure host OS re-enumerates.
This is the related code.
https://us.codeaurora.org/cgit/quic/la/device/qcom/common/tree/rootdir/etc/init.qcom.usb.rc?h=LA.BR.1.2.4_rb1.45

I am not sure how this cause you trouble for the adb.
When adb is not working, common cause is having some device connected to USB-TypeA connectors, when using microUSB connector for adb but I am not sure this is the case for you.

By the way,
with the words “David Jones” and “Australia”, I came up with a different person who host eevblog. :slight_smile: