Windows PC does not recognize Dragonboard


#1

I seem to have a slightly different problem trying to load the USB drivers. After connecting the micro usb cable to my PC using Windows 8.1 the Device Manager does not show the android icons. I have tried using a different micro usb cable and I even used a second computer running windows 7 with the same results. I then bought a second Dragonboard figuring that there was something wrong with the board but I have the same results with the second board. I tried disabling driver signature enforcement but that didn’t work. Does anyone have any ideas?


#2

Please make sure you have the driver installed first. Re: http://www.96boards.org/forums/topic/dragonboard-faq (Q: Why the DragonBoard 410C does not recognized by adb on windows?)


#3

I have the driver in my usb_driver folder which is in my google folder which is in my SDK folder which is in my Android folder which is in my Programming folder which is in my Rich folder which is in my Users folder which is in C:. So it goes C: Users Rich Programming Android SDK usb_driver android_winusb.inf. Am I supposed to do anything else before plugging in the micro usb wire? I know that once the Device Manager recognizes the Dragonboard I should direct it to this file but the Device Manager doesn’t recognize the board so I can’t direct it to go to this file. What am I supposed to do to get the Device Manager to show me the Android devices?


#4

Please use below guide to install the driver.
http://www.96boards.org/forums/topic/step-by-step-instruction-to-install-adb-usb-driver-on-windows/


#5

I have done the steps in that link. I opened the Device Manager. I downloaded the driver and put it into the USB_driver folder. I disconnected the mouse and keyboard that were plugged into the 2 USB ports. I connected the Dragonboard to the PC with the micro USB cable. I connected power to the Dragonboard. I look at the Device Manager and nothing has changed. I have no “Other devices” shown, and I have clicked on “show hidden devices”. I have clicked on “Scan for hardware changes”. I have expanded all the icons and nowhere do I see Android anything. I have repeated all this after disabling Signature Enforcement on the windows PC. I have repeated this with 2 different Dragonboards and 2 different micro USB cables. What else can I try?


#6

Hi Rich,

Sorry to hear that. The steps look correct so not sure what else to try either.
A quick search online reveals this - http://ms-iot.github.io/content/en-US/win10/SetupPCDB410c.htm.
Maybe you can try the update tool which includes a driver as well.
Note that I’m assuming you want to use this for Windows IoT, and if so, you might also get more info/help from https://developer.microsoft.com/en-us/windows/iot/getstarted.

HTH


#7

Thanks for all your help. I’m taking the Coursera course and since my PC doesn’t recognize my board I guess my course has ended. Maybe I should try to send these two worthless boards back and get a refund.

Rich


#8

Hello Rich,

I quickly scanned this issue, I wanted to check if you enabled USB debugging on your board?

This is assuming you are running the Android OS. If you did not enable USB debugging in the Developer mode options, even with the drivers, you will not detect the board.

  • Robert W

#9

Robert,

Your response triggered a lot of ideas/questions that I didn’t pick up from the course so far. On the original board I got from Arrow I changed the operating system to Linaro but before I did that I activated my developer options and activated USB debugging. The second board which I got from Amazon came with Linaro pre-installed. After Linaro is installed on the board, is there ever a need to use the micro USB cable. If there is ever a need, is there a way to activate USB debugging from Linaro? I’m now guessing that by using Linaro, that all commands to the board for running the GPIO pins and sensors are done thru the keyboard and mouse and that I will never talk to the board using my PC. Is this true?

Rich


#10

@Rich

Okay so I will try to address all of these questions.

  1. The reason one of your DragonBoards shipped with Android and the Other shipped with Linux Debian: Arrows offers: the DragonBoard 410c “Vanilla” which is essentially just the DragonBoard only (this one comes with Android pre=installed), then there is the DragonBoard 410c AWS kit, and this one comes with a power supply (with Linux Debian pre-installed). I am guessing you purchased the Vanilla board first, then you purchased the AWS kit second. The boards are exactly the same, they are just shipped with different SW.

  2. If you are running Linux Debian you do not need to enable USB debugging(that is only for Android), in general, you will not need to connect a USB to the board via the on board microUSB either. On Linux Debian all development is done directly on the DragonBoard. You can simply hook up a keyboard and mouse, open up a terminal window and begin programming.

The Coursera course is almost evenly split between Android and Linux Debian, though you are welcome to attempt the exercises using only Debian.

It is true that you should not need a host pc anyone once you have flashed the Debian images to your board.

Rich, please stop by OpenHours tomorrow. I would be glad to talk to this point if you would like on our call.

www.96Boards.org/OpenHours

We will also be interviewing some engineers from STM who will be talking about ESD protection and some other cool stuff.

I hope this helps.

  • Robert W.

#11

Robert,

Thanks so much for getting right back to me. For some reason not needing to connect my PC to communicate with the Dragonboard while using Linaro went right over my head, even though I must have watched those videos 4 times. Oh well my main goal was to learn about the Dragonboard and I have. I can now get back to the two courses. I will try to tune in tomorrow for the OpenHours. Thanks again.

Rich


#12

@Rich

I look forward to seeing you! :smiley:

Feel free to give our new mailing list a whirl too if you like at www.96boards.org/newsletter/digest

Take care,

Robert W.


#13

I am learning Drangonboard 410c from coursera , but I get stuck when my dragonboard did not recognize by android studio. I added all the qualcomm devices list in android_winusb. When I connected the micro usb for the first time , in device manager I saw three android devices showing in other devices and suddenly setup pop up box appeared showing setting up necessary files and it stopped in the middle. After that I tried to connect again , but it is only shownig adb interface in other devices of device manager and also unable to update driver software. This dragonboard is not also recognized by android studio, where as my other samsung devices are recognized by it. Someone plz help me…


#14

Hello,
here is what I see when I connect the DB410

It is defined as Modem and also as COM port.
Modem would be the ADB link and the COM port when you use the Console.

If you do not see this it is better to install the drivers again. You probably have a device connected which is not correctly defined, so click on it and install manually the drivers (the one you downloaded).

Then use ADB to see if your device is connected do not try using Android studio.
Use the cmd prompt terminal and go to your Android installation directory.
and then go to the SDK (cd sdk)
then go to platform-tools. (cd platform-tools)
then type “ADB devices” and you should see your devices listed.

If you have more question just come back.
jean-marc


#15

Hello @jmjobin

even my windows pc does not recognize dragonboard 410c and i am using command prompt.when i typed adb devices it shows “adb is not recognized as an internal or external command” ? i installed adb but still not getting why this problem persists ?please help

thanks in advance!!!


#16

Hello @ren_snappy, did you install Android SDK in your pc?


#17

Hello @jmjobini
yes sir i had installed .


#18

Well why did you “install” ADB? ADB is part of the Android SDK.
Go to the Android\sdk\plateform-tool.
You should find adb.exe