WiFi channel 36 no IR sometimes

Hi I am using snapdragon 820. I noticed that sometimes channel 36 becomes no IR. Please see in the picture below. The channel was available when I flashed the img to the board. How do I make it available again?

Also many channels are disabled by default. I would like to know where I can change in kernel to enable all channels by default? Is this possible to change settings and rebuild kernel to enable all channels?

I was trying to use country code in hostapd.conf configuration file. But it doesnt work.

Many thanks

Maybe try to install crda:

apt-get install crda

And change the country code:

iw reg set US

Thank you very much for the reply.

CRDA does allow me to change the region.

However, now it shows two region settings. One is for global and one is for phy#0

root@linaro-alip:~# iw reg set GB
root@linaro-alip:~# iw reg get
global
country GB: DFS-ETSI
(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
(5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)

I use the command to set region to the UK. It only sets global one. Is there anyway to set phy#0 one? Is there any way to set region from source code? Or is it not possible to do this?

Many thanks

Well you can probably change this directly in the driver: https://git.linaro.org/landing-teams/working/qualcomm/kernel.git/tree/drivers/net/wireless/ath/regd.c?h=release/qcomlt-4.14#n702

But ideally you should check if the country change notifier is called, and if dynamic country code change is allowed: https://git.linaro.org/landing-teams/working/qualcomm/kernel.git/tree/drivers/net/wireless/ath/regd.c?h=release/qcomlt-4.14#n507
Maybe a flag or config is missing…

Thank you very much for the help. This is what I am looking for.