Wcn36xx AP Dropout


#22

Hi, did you solved this issue? I noticed here in my tests that wcn36xx has a problem when uses WPA/PSK encryption, the connection falls and AP only returns when execute:

modprobe -r wcn36xx
modprobe wcn36xx

So I assume that the problem is related to wcn36xx because I restarted Network Manager and wlan0 interface but only when I restarted the wireless module the AP went back to normal functionality.


#23

Yes it seems to be a firmware issue. After few group rekeying, firmware seems unable to send TX packet. A workaround is to set wpa_group_rekey=0 in hostapd.conf for this issue.


#25

It works! Thanks a lot. Is there a way to configure DHCP for this AP? I’m using hostapd with fix IP address.


#26

I did it, soon I’ll return here all the steps to workaround this firmware issue.

Thanks!


#27

Hi, I’ve used this configuration to set AP:

Tested with the images bellow:

    * Download rescue files with version 108 (dragonboard-410c-bootloader-emmc-linux-108.zip):
    https://snapshots.linaro.org/96boards/dragonboard410c/linaro/rescue/108/
            
    * Download image files from version 530 (linaro-buster-developer-dragonboard-410c-530.img.gz and boot-linaro-buster-dragonboard-410c-530.img.gz): 
    http://snapshots.linaro.org/96boards/dragonboard410c/linaro/debian/530/
  • Disable power management:
    sudo iwconfig wlan0 power off
    sudo iwconfig wlan0 txpower auto

  • Configure hostapd.conf:
    sudo nano /etc/hostapd/hostapd.conf

  • Insert this information, save and exit:
    interface=wlan0
    driver=nl80211
    channel=6
    ssid=AccessPoint
    hw_mode=g
    wpa=3
    wpa_passphrase=1234567890
    wpa_key_mgmt=WPA-PSK
    wpa_pairwise=TKIP
    rsn_pairwise=CCMP
    auth_algs=1
    macaddr_acl=0
    ht_capab=[DSSS_CCK-40][SHORT-GI-20][HT40-]
    wpa_group_rekey=<0 or Big number>

  • Stop NM (NetworkManager):
    sudo systemctl stop NetworkManager

  • Set DHCP:
    cd ~
    sudo nano dnsmasq.conf

Insert:

Interface to bind to

interface=wlan0

Specify starting_range,end_range,lease_time

dhcp-range=10.0.0.3,10.0.0.20,12h

  • Apply Settings:
    sudo dnsmasq -C dnsmasq.conf

  • Set network in wlan0:
    sudo ifconfig wlan0 down
    sudo ifconfig wlan0 10.0.0.1 netmask 255.255.255.0 up

  • Run AP with:
    sudo hostapd -B /etc/hostapd/hostapd.conf

  • Use arp command to see connected devices IP:
    sudo arp

  • ping IP address:
    ping Address | perl -nle ‘print scalar(localtime), " ", $_’

  • If ping fails and AP stop working, execute:
    modprobe -r wcn36xx
    modprobe wcn36xx
    systemctl restart hostapd@wlan0