Waiting for device


#1

hikey 1G board, link 1 -2 closed, link 3-4 closed. power connected microUSB connected. NO LED lighted

dmesg:
[ 618.902764] usb 6-3: new full-speed USB device number 3 using ohci-pci
[ 619.069959] usb 6-3: New USB device found, idVendor=12d1, idProduct=3609
[ 619.069965] usb 6-3: New USB device strings: Mfr=1, Product=4, SerialNumber=0
[ 619.069970] usb 6-3: Product: \xffffffe3\xffffff84\xffffffb0㌲㔴㜶㤸
[ 619.069974] usb 6-3: Manufacturer: 䕇䕎䥎

running:
sudo python hisi-idt.py -d /dev/ttyUSB0 --img1=l-loader.bin
done.

LED0 Lighted.

but:
sudo fastboot flash ptable ptable-linux-4g.img
waiting for device

please help.


#2

Is your linux in a virtual machine hosted by Windows or OS X?
What distro and version are you using?
What’s the output of below commands?
sudo python hisi-idt.py -d /dev/ttyUSB0 –img1=l-loader.bin
sudo fastboot devices


#3

It was connected with a native Ubuntu 15 PC.

output of: sudo python hisi-idt.py -d /dev/ttyUSB0 –img1=l-loader.bin

±---------------------+
(’ Serial: ‘, ‘/dev/ttyUSB0’)
(’ Image1: ‘, ‘l-loader.bin’)
(’ Image2: ', ‘’)
±---------------------+

(‘Sending’, ‘l-loader.bin’, ‘…’)
Done

output of: sudo fastboot devices
< waiting for device >


#4

Do you have console logs to show what’s going on in the board?

Also, are you using the latest burn-boot repo? Can you try commit 7963d1c055bce78912067c8b4aa42b686c1912dc, and use below command instead?
sudo python hisi-idt.py –img1=l-loader.bin


#5

I think the appearance is Serial Number of my HiKEY device has gone.

as a comparison, once i connected a normal Android phone as Fastboot mode, by running dmesg:

[ 1855.045068] usb 1-2: new high-speed USB device number 6 using ehci-pci
[ 1855.179383] usb 1-2: New USB device found, idVendor=0bb4, idProduct=0c01
[ 1855.179401] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1855.179410] usb 1-2: Product: Android
[ 1855.179419] usb 1-2: Manufacturer: MediaTek
[ 1855.179426] usb 1-2: SerialNumber: 0123456789ABCDEF

you can see the last line of Serial Number of an Android phone connected, but my HIKEY device never shows the last line.
Maybe “Fastboot” function of my HIKEY has gone or broken?

my HIKEY was running fine, but after i run “sudo python hisi-idt.py -d /dev/ttyUSB0 –img1=l-loader.bin” again, i can not use fastboot function as it always shows <waiting for device>


#6

Hi,

I’m having this same problem. I’m trying to flash OP-TEE OS on to the HiKey board. It works fine until the first ‘fastboot’ command where it sits forever at ‘< waiting for device >’. ‘dmesg’ shows the correct information for the board as well. Anybody know how this was solved or where to proceed?

Thanks,
B


#7

Never mind. I found that running the commands as root worked. For some reason, fastboot could not see the board unless as root (compared fastboot devices to sudo fastboot devices)

Hope this helps.