Using Ubuntu-Core on dragonboard 410c


#1

Hey, I am flashing the Ubuntu-core sd card image onto dragonboard 410c. On startup it shows some logs along with asks for login.
I applied ubuntu as a passwd and username. I also tried linaro. still I am not able to login. It shows like wrong username or passwd. Please help me to login.


#2

Documentation for Ubuntu Core comes from Canonical: https://developer.ubuntu.com/en/snappy/start/dragonboard-410c/

I believe the device does not use traditional usernames and passwords.

Instead during the initial setup of the device you should be logging in with your Ubuntu SSO credentials and, providing you have uploaded it, the DB410C will automatically download your SSH public key from Ubuntu servers.


#3

Yup I uploaded the Ubuntu SSO credentials. It’s generating public key. But after that again it asks for username and passwd.


#4

According to the Canonical documentation (the “Login” and “First login tips” sections), after you have Finished the setup you must connect to your device using ssh rather than attempting a local console login (because password login is disabled by default).

Note also that the login tips also tell you how to set a password and enable local console login.


#5

Yup I also tried for the same. But still I am not able to ssh to the device.


#6

Console Logs:

Ubuntu Core 16 on 127.0.0.1 (ttyMSM0)

localhost login:

It directly shows like this after boot up. Now I am trying for ssh to board for changing the password. still I am not able to find IP address on logs. Directly it shows the login prompt.


#7

If you’re on a home network (or have a relaxed IT dept) then perhaps try an nmap ping sweep? Alternatively you could try reimaging the SD card from scratch which (I guess) will rerun the first start wizard… that definely shows the current IP address.


#8

Thanks danielt.
After reimaging the sd card, It shows the folliwing logs:

Ubuntu Core 16 on 10.99.7.42 (ttyMSM0)

localhost login:

And after that I am trying to login with SSH into Ubuntu Core by
ssh user-name@10.99.7.42
As per docs it doesn’t have to ask for password. still it asks for password and if I enter ubuntu login password then it shows wrong password.


#9

I’m not quite clear whether after re-imaging you got the first start wizard or not. It would be good to know that. Taking a look at the output of “ssh -v user-name@10.99.7.42” would be useful. That should give you some idea of what SSH key you are sending to the board (check this against your Ubuntu SSO profile).

At this stage I can offer you a works-for-me ™. I managed to install Ubuntu Core and login (then I nuked it and went back to Debian :wink: ). Anyhow, I was a little surprised at what my Ubuntu username actually was (I didn’t remember it until I looked it up on my profile) but other than that it went smoothly).


#10

ssh -v user-name@10.99.7.42
Logs:
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/megha/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/megha/.ssh/id_dsa
debug1: Trying private key: /home/megha/.ssh/id_ecdsa
debug1: Trying private key: /home/megha/.ssh/id_ed25519
debug1: Next authentication method: password

I think it matches the private key. But I already import the public key on Ubuntu one profile.


#11

I’m a bit unnerved by the “I think it matches” :wink: . The purpose of this sort of test is so we can know it matches! Thankfully we can test that if you have the regular GNU/Linux PC to test with.

If you take the SD card out of the DB410C and connect it to your PC then you should some of the partitions on the card automount. One of the partitions is called “writeable” and should contain your SSH public key and you can compare it byte-for-byte with /home/megha/.ssh/id_rsa.pub .

For me the key is found in (note that there might be an extra /var at the front for you):

/run/media/drt/writable/user-data/daniel-thompson-s/.ssh/authorized_keys

You should check that the <user-name> you are using matches the directory name (“daniel-thompson-s” for me) and that the contents of id_rsa.pub and …/authorized_keys match.


#12

I used to create a tutorial on how to bring up a Ubuntu Core for dragonboard. You may find the tutorial at:

http://blog.csdn.net/ubuntutouch/article/details/53036627

Though it is a Chinese content,you can google translate it.

Basically:

  1. You need to have a ethernet adapter for connecting to network
  2. Connect your board and computer to the same board so that they are in the same network. By entering the “admin” page of the router, you will be able to find the IP address of the board. You may find the guide at:

http://blog.csdn.net/ubuntutouch/article/details/49735883

You may also use the command:
$ nmap -sn router_admin_IP_address/24

to get a list of all of the IP addresses on the router network. Then try the following with each IP address

ssh Ubuntu_SSO_account_name@IP


#13

Yup I am able to bringup Ubuntu core on dragonboard. Thanks