USB Power / OTG


#1

Hello there :slight_smile:

I try to put a USB easycap on the dragonboard, I have 1 that power the usb module fine and another not, what’s the max power that USB can deliver and what can explain the difference between the 2 boards ?
If I put it on the USB OTG nothing is powered, no matter on the S6 switch, how can I make it work with a debian image ?

Regards
Nicolas


#2

Hi @Ntis

The official power limit of the output from USB port of 96boards is 5V and 500mA.
I see many people having the same issue on the Raberry Pi with the USB easycap.

I do not have the USB easycap and have not tried by myself but many people are able to use the USB easycap by connecting the powered USB hub which could draw 1A between the USB port and the USB easycap.

Please let me know if it works.


#3

Hello,

The easyCap is annouced to draw 300mA which could by supplied by the 500mA of the USB norm, I don’t put a multimeter to check that and yes if I use a powered hub it works, but on another board (I have only 2 for the moment) it works out of the box no more power needed. Is there a way to use the otg as an host port to avoid the usb multiplexer chip ?


#4

I made mesurement and my easycap drawn 150mA, any idea on why it is this sufficient to short circuit the USB mux ? (voltage drops to 0.7V)


#5

Hi @Ntis

Unfortunately, even the easyCap is annouced to draw 300mA which is in specification of 500mA and should work from the limitation of the specification, many USB devices fails to work in reality.

There could be many reasons for this, but most common causes are the ripple noises, common mode noises and differential noises with the combination of the USB host and the USB devices.

If you have two easyCap and if they work on J2 or J3, I only could advice to use the easyCap on J2/J3 with USB host mode, and not using the easyCap on the J4 with USB-OTG.

Also, when you measured 150mA with your multi-meter the voltage drop of 0.7v could be caused by internal shunt register in your multi-meter. This happens to my multi-meter too.

I hope it help you for using the easyCap.


#6

Hello,

In fact the 0.7V is the voltage remaning on the usb port when easy is plugged (no current measuring in this case)
and I have only 1 easycap that I plug on 2 dragonboard, 1 dragon is working, the other not. If I use only resistor to draw 200mA I reproduce the problem.
I would like to try with J4 (usb OTG to check is the USB mux can be in cause) but I can’t activate it, I don’t really know how in fact (the S6 switch did nothing) DO you have a clue for me to test it ?


#7
and I have only 1 easycap that I plug on 2 dragonboard, 1 dragon is working, the other not. If I use only resistor to draw 200mA I reproduce the problem.

This is odd that the easycap do not work on one of your dragonboard out of two.
The only remaining idea I could have is that the quality of the AC adapter.
Also, some of the DC plug converter has different outer diameter, the 96Boards uses EIAJ3 jack which require 4.75mm outer diameter and 1.7mm center pin.
The EAIJ2 plug will fit on 96Boards but it will cause problem, since the outer diameter of EIAJ2 plug is only 4.0mm and cause week ground connection.

If you are using the same AC adapter for the two dragonboard and not using any DC plug converter, then it might be good to contact Arrow and explain the voltage symptom.


#8

Yes really weird, same plug 2 differents boards, make me feel that this is a hardware problem. I’m waiting for 3 other boards and I will check for the rate of ‘defect’ to see if this is an isolated case.


#9

Hi @ntis:

The 410c Board is designed to deliver 1.18 Amps from each of the Type A USB 2.0 ports. The current is measured and limited by the TPD4S214YFFR chips on the board. We intentionally set the current limit very high because we know from (bitter) experience that many “USB compliant” devices draw far in excess of the 500mA limit. The remaining power system on the board (the 12V to 5V stepdown) has also been designed to handle the worst case where both USB ports are drawing 1.18 Amps, all while the mezzanine card is also drawing the max possible current.

A “compliant” USB device should only draw 100mA during the enumeration phase, and then should request permission to draw more current, if permission is granted then the device may draw up to 500mA. The Type A ports on the 410c don’t limit at 100mA or even 500mA during the startup and enumeration phases. If the device draws in excess of 1.18A (for example when first plugged in to charge the capacitors) The TPD4S214YFFR will limit current, but it will retry again almost instantly.

The micro USB port (J4) is a different beast. It actually enforces the power rules when you plug in a device. If the EasyCap is drawing 150mA without requesting more power then it will get shut down. The current measurement mechanism is not really accurate, so just the differences between individual DragonBoards may explain why it works on some boards.

The micro USB port on the DragonBoard is supposed to be a “Type B” port, it is not a “Type A-B” port, you can see pictures here: https://commons.wikimedia.org/wiki/File:Micro-USB-jacks.jpg. A “Type B” port is intended to be a device, not a host. You must be using an unusual cable that allows you to connect a device to the micro-USB port on the DragonBoard. As you have seen, it will work, but that was not the design intent.

Is there any reason why you are not using the Type A ports?.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#10

Hello,

Thanks for this full answer, I don’t want to use B rather than A port, I just want to know why the usb is not revceiving power and try to bypass the limitation if it was possible (I remember a schematics where it shows a difference of routing between J4 OTG and the other host port)
I tried the 3 boards I received yesterday and power is effective on the easycap. These 3 board have not the same looking of mine that is not working (not the same color, and marking is different) so as a first impression I’d like to say that a series of board have a missconfigured current limiting sensor for the TDA (verified with resistor, voltage begin to drop from 100mA) but I can not be affirmative because I got 4 boards of a type that works and 1 of other type that doesn’t work.
Hope I won’t get theses other one while in production …

Nicolas