USB not working


#1

my dragonboard arrived today, so i connected the board up to my mouse, keyboard and monitor.
powered it up on my 12volt powersupply.

turned it on and it booted up with the dragonboard splash screen quickly followed by the standard android login screen.

i try to drag up the screen with the mouse but realized that there was no mouse pointer.
at which point the screen blanked, and the board went to sleep.

after playing around and resetting the board a few time i noticed that the mouse wasnt getting any power, and its red laser/led light wasn’t being powered.

so i checked that the mouse works with my laptop and its fine.

so plugged it back into the dragonboard and booted everything. still no power to the mouse.
so i connected my iphone into the dragonboards usb to see if it would charge it, and no luck there either.

do i did a big of googling and found that i might need to update to the latest firmware.

so i copied the lastest version of andriod from here (https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android)

followed the process of getting the image onto the SD card. and set the dip switched to boot of the SD card.
rebotted the dragonboard and it displays a dialog box to confirm the updated.
but as i cant get the mouse or keyboard to work i can update the firmware this way.

ive did a bit more of a search on the forum, and notice that im not the only person to encountered this problem.

can some one give me some light as to why im getting this issue??? and how can i get this solved quickly.

cheers,
David.


#2

It sounds like there might be some hardware issues with your USB port or the board itself. You may have to exchange your board. If you have a volt meter I would try to check the voltage between pin 1 and pin 4 of the usb port. See if you are even getting any power to the USB ports or not.


#3

Im hoping that someone can point me to where others have had this problem had were able to fix it.

Im in new zealand and dont really want to have to send the board back.

David


#4

Hi David

Have you left the USB micro cable plugged in? The SoC used in this board has only one USB port and cannot support simultaneous use of the USB micro socket and the big USB type A sockets. If there is anything plugged into the USB micro socket then the other USB sockets are automatically disabled (including power).

Daniel.


#5

i only have the HDMI, mouse and keyboard plugged.


#6

Shame. That certainly does hint towards a hardware problem.

If you have a USB OTG adapter it might be a worthwhile experiment to remove the mouse/keyboard, and reconnect the mouse using the USB OTG adapter (i.e. connect a mouse via the micro B socket). If there is a fault in the built in USB hub this might avoid it.

Another thing to try (although its a bit of a long shot) it to install debian instead. It is not that debian is any more reliable but that it is easier for us to suggest diagnostic tools there. That said… if your hardware really doesn’t work then debian isn’t going to fix it.