Unable to work via serial


#1

I’m trying to install Debian on HiKey 960 by following https://wiki.debian.org/InstallingDebianOn/96Boards/HiKey960 . In fact, I had to postpone my installation a month ago, because I couldn’t see what was happening without a 96Boards UART. Now that I’ve got one (shipped from China), I can see a GRUB menu (Debian GNU/Linux; Advanced options for Debian GNU/Linux) and make a choice from my keyboard. (I use minicom for this.)

Unfortunately, it all ends pretty quickly with:

linaro-developer login: root (automatic login)

Last login: Thu Nov  3 17:16:44 UTC 2016 on ttyAMA6
Linux linaro-developer 4.15-hikey #1 SMP PREEMPT Sat Mar 10 22:41:04 UTC 2018 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
root@linaro-developer:~# [    7.911406] wlcore: PHY firmware version: Rev 8.2.0.0.240
[    8.019346] wlcore: firmware booted (Rev 8.9.0.0.76)
[    8.041077] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    8.049881] wlcore: down
[    8.184208] mmc_host mmc1: Bus speed (slot 0) = 400000Hz (slot req 400000Hz, actual 400000HZ div = 0)
[    8.227654] mmc_host mmc1: Bus speed (slot 0) = 25000000Hz (slot req 25000000Hz, actual 25000000HZ div = 0)
[    8.653521] wlcore: PHY firmware version: Rev 8.2.0.0.240
[    8.771345] wlcore: firmware booted (Rev 8.9.0.0.76)
[    8.792923] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    8.979082] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

After this, my keystrokes do nothing, i.e. I can’t send anything to the board. (I know how to set up wlan0 from command line, but I can’t get there unfortunately.) In other words, I’m stuck. Please help!


#2

@psyhtest Please check if you have turned off hardware and software flow control option while connecting using minicom.


#3

screen /dev/ttyUSB0 115200


#4

Thanks! Works like a charm after switching off the hardware flow control.