Unable to make LED ON/OFF


#1

Hi,

I followed video provided at : https://developer.qualcomm.com/hardware/dragonboard-410c/tutorial-videos , exactly all steps are followed as mentioned bit i am not able to make LED ON/OFF.

I checked LED separately via connecting to battery and it is working fine.
I checked + and - sign of LED as mentioned (+ on 23 and - on 1 ) still i am not able to make LED blink.

Could you please guide , how to debug it.

Regards,
Avinash


#2

Hi @avi141

I don’t have a Android DragonBoard set up right now, so I haven’t tested that the instructions in the video are still valid, but I have a few ideas about things you can try to get it working.

The first thing I would check is the specifications on the LED. The signal levels on all of the 96Boards are 1.8V, this is much lower than the voltages from other maker boards (usually 3.3V, or 5.0V). The LED needs to be a red LED, most (but not all) red LEDs will turn on at least dimly with a 1.8V drive signal. Green or Blue LEDs usually need an extra volt or so to turn on (i.e approximately 2.8Volts) to turn on. What voltage battery did you use to test your LED? was it a 1.5V battery (an AA cell or similar), or was it a higher voltage battery (a 2.7V lithium Ion battery).

Other things to check:
Did you receive any error messages while entering the adb commands?
Did you connect to the correct pins on the connector?

Full Disclosure, I am an employee of Qualcomm Canada. Any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#3

Thanks for reply ljking.

  1. You might be correct ; I am using green color LED , an di tested it with AA battery. I will buy a red color LED and verify and confirm.

  2. No error message in adb commands, all commands get succedded.

  3. Yes(based on video), I connected correct PIN. -ve at slot number 1, and +ve at slot number 23. I tried swapping it also , but unfortunately it not worked.

I will update on my findings.

Regards,
Avinash


#4

Since you are using a Green LED, I would suspect this is the cause of your issue. A typical Green LED needs about 2.1V to light up, but the low speed connector only has 1.8V outputs. These outputs are not a really good way to drive LEDs and this should only be used to do a quick check that you are actually driving the GPIO.

Full Disclosure, I am a employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#5

Thanks, I am able to founnd a red LED , and it is blinking (not consistent ON), might be again voltage issue.
Can i check GPIO output via adb shell (command prompt). Currently Android is installed on board.

Regards, Avinash