Unable to enumerate USB device

I have the core board and carrier connected to a linux laptop via USB C. lsusb doesn’t show any device. dmesg states “unable to enumerate USB device”. Windows states that the device is disabled due to an invalid device descriptor. The Windows driver is installed.

Any suggestions?

Possibly worth noting that I don’t have a screen connected, but hoping it doesn’t matter. Doesn’t seem like it should.

Managed to get around that; suppose I wasn’t holding the maskrom button vigirously enough.

I’m now able to run the upgrade tool, but the command

ul MiniLoaderAll.bin

gives “Creating Comm Object Failed!”

Thanks

Managed to muddle through. The error I was getting seems intermittent.

New problem, naturally :).

I have successfully flashed the Linux image, but I guess the ethernet is not configured because it doesn’t appear on my network. Any way to get it configured without a monitor? Looking ahead, it also seems likely that ssh is not installed or enabled. If not, any realistic way to achieve that without a screen?

Thanks

Have you tried the UART console?

No, I’m afraid I don’t know how and having a hard time finding any useful documentation. Any pointers you can offer?

You have hardware user manual here: https://www.96boards.org/documentation/som/tb-96aiot/hardware-docs/

You can use the USB debug to access UART output, I don’t know the baudrate, but it is likely either 115200 or 1500000.

reference:

Thanks again for your support. I have seen the hardware manual but I’m a bit of a novice to some of this stuff so doesn’t give all the information I need. Nevertheless I did manage to get the UART debugging going, and got some output at speed of 1500000.

DDR Version V1.04 20191121
LPDDR3
933MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS=1 Die BW=32 Size=1024MB
out
Bootl Release Time: Dec 9 2019 18:18:13, version: 1.05
chip_id:524b186,0
ChipType = 0x15, 10271
sfc nor id: ff ff ff
sfc_nand_id: ff ff ff
NeedKHz=200KHz,clock=12000KHz
NeedKHz=200KHz,clock=12000KHz
NeedKHz=200KHz,clock=12000KHz
NeedKHz=18000KHz,clock=192000KHz
NeedKHz=48000KHz,clock=192000KHz
mmc2:cmd19,100
SdmmcInit=2 0
BootCapSize=2000
UserCapSize=7456MB
FwPartOffset=2000 , 2000
SdmmcInit=0 NOT PRESENT
StorageInit ok = 20602
SecureMode = 0
Secure read PBA: 0x4
Secure read PBA: 0x404
Secure read PBA: 0x804
Secure read PBA: 0xc04
Secure read PBA: 0x1004
1806 loader need rk sign!
SecureInit ret = -1, SecureMode = 0

So this is all about the CPU naturally. Most of it seems reasonable, or at least doesn’t suggest anything problematic to me, but the last couple of lines suggest a problem. From what I’ve seen a return of -1 is never good haha. Mean anything to you?

Thanks.

I’ve tried both prebuilt Linux images. The 2019 release appears to boot, at least according to the debug output. But it is Android and not what I want, and it doesn’t seem like the Ethernet works. The 2020 release simply doesn’t boot and I get the output shown above.