Ultra96 not booting from SD card

I know that this topic has been addressed before as in here:

and here


One thing that I have to mention is that I overwrote the 16 GB micro SD card that that my Ultra96 board came with, with a petalinux build, with all of the proper BOOT.BIN and image.ub on partition 1 and the rootfs.ext4 on partition 2. I was not aware that the micro SD card that came with my Ultra96 contained the factory configuration. For all of the above I used fdisk.

After power on, I have no indications, with the LEDs on board, that the device is booting. Lights are on when I press SW4 but nothing flashes and I see no action on the blue LED.

I also found the “pre built” directory and used the BOOT.BIN and image.ub from there. No luck.

Instructions say to momentarily press SW3 but SW3 is not a push button but a select switch with two positions, which I have clearly set to the correct configuration ( I even tried the other configuration just in case but to no avail).

I have tried to set the SD card back to the factory defaults by following the instructions in:

The factory image that I downloaded was Ultra96_rev1_sdcard_image_180409.img and I used etcher to burn the image.

Still no result. It just appears that the system is either not looking to the SD card for boot instructions or that the boot instructions are incomplete. My guess is the former.

What would I do at this point?

Tom Cipollone

@miner_tom As I mentioned in your previous post, the image available on the 96Boards documentation repo is for Ultra96-v1 so it won’t work on v2.

You can download the initial v2 image from Avnet’s site in the meantime. I’ll remove the link to v1 image from the repo.

Sorry for the inconvenience.


Thank you so much for the advice. Yes, I was able to find the v2 image file and burn the image. I am now getting a heartbeat of blinking leds. The Ultra96 is finally booting!

However, one last problem if I may impose. I am attempting to communicate with the board via the jtag breakout board connected to a usb port on my desktop, running ubuntu 16.04. Putty is not able to initiate serial communication. I did visit the ftd chip site, www.ftdichip.com/Drivers/VCP.htm, and I read the following:

“All FTDI devices now supported in Ubuntu 11.10, kernel 3.0.0-19”

There was some additional verbiage about adding a custom installation but I am wondering if there is a simple solution to what I am experiencing.

I hope that the screen shots of my putty configuration and my serial device configuration come through and they are attached below.

Thank you again for the help so far. I am looking forward to communicating with the board.

I have since tried to communicate with the Ultra96 using Windows 10 and Putty. There is communication but the results are gibberish. Probably a setting that I have that is incorrect in Putty. Can you give me a suggestion?

Hi Tom,

Are you running Ubuntu native or in a virtual machine? If in a virtual machine you will want to be sure the “Xilinx JTAG+Serial” device is passed to the VM for Ubuntu to use:

For the UART to be usable in Ubuntu the FTDI VCP drivers will have to be installed on the host OS first. It sounds like you have already done that?

Once you have done all that the UART should be found at /dev/ttyUSB1 at baud 115200 (GtkTerm command “gtkterm -p /dev/ttyUSB1 -s 115200”).


Thank you for your reply.

I have two systems where I have attempted to communicate with the Ultra96. One is Ubuntu 16.04, native (not virtual). The second is windows 10. I came close with the windows system, and the Ultra96 is communicating in some fashion but the results were garbled. I was not able to establish communication with the Ubuntu system at all.