Ubuntu-Core support


#1

Hi,

I am trying to install an app in Ubuntu-core.

‘snap list’ command gives me error:

snap list

error: cannot list snaps: cannot communicate with server: Get http://localhost/v2/snaps: EOF

And when I am trying for below command:
$ systemctl status snapd.refresh.service
● snapd.refresh.service - Automatically refresh installed snaps
Loaded: loaded (/lib/systemd/system/snapd.refresh.service; static; vendor preset: enabled)
Active: inactive (dead)
Docs: man:snap(1)

I am not able to install any app in ubuntu-core. It gives the error as listed below:
error: cannot communicate with server: Post http://localhost/v2/snaps/hello-world: EOF

I also tried to include the ‘.snap’ app in command while preparing finale image, still it doesn’t worked.

The another issue I am facing - wifi is not working, even though the module for that is present while preparing finale image.

ifconfig wlan0 up

wlan0: ERROR while getting interface flags: No such device


#2

Isn’t this related to your other thread? It sound like it is caused by your version of the rootfs not support WiF.


#3

@Megha

There are several things going on around Ubuntu Core these next few weeks.

I would suggest tuning into OpenHours tomorrow at 4:00p UTC / 8:00a PST: www.96Boards.org/OpenHours
It’s free, live support!

It just happens that We will be hosting several Ubuntu Core developers, they will be on the call for over an hour to take any questions you may have.

I would also suggest joining the #ubuntu-on-air and #OpenHours channel in IRC

Find me there with handle sdrobertw

If you are unable to make the show tomorrow, I will be sure forward this question to the crew, and post the shared video here once it hits YouTube.

Thanks!

Robert W.