UART1 using for zigbee interfacing with DB420c


#1

Hello ,anybody worked on UART1 using for interfacing wireless device like zigbee. I am using UART1 for zigbee interfacing. i write one simple c program to access /dev/ttyHSL0 in android.but i am not able to communicate with zigbee.i made # CONFIG_SERIAL_MSM_HSL_CONSOLE is not set ,in config file.so i will get my data properly.
i am using level shifter for 1.8v to 3.3v.
whatever the code i wrote using that program i am able to send data to minicom console.but same program is not sending data to zigbee.

I am not getting the exact issue.please anybody help me.


#2

Great stuff, where did you find that CONFIG_SERIAL_MSM_HSL_CONSOLE will disable the console, what document?
Did you try to use UART0?

I am asking because it is a while that I am trying to understand why I cannot receive data properly on UART0…
Slowly trying to collect info… Using Android too.


#3

I am not using UART0.In arch msm_defconfig file you will get this CONFIG_SERIAL_MSM_HSL_CONSOLE option.and one more thing i did is in BoardConfig.mk file i disabled the console parameter.


#4

as per my knowledge i came to know that issue is not in my c programs.when i give connections of UART1 to level shifter. and when i start sending data.I checked that voltage at uart1 pins is boosting to 2.1v from 1.8v.


#5

OK, I know you are not using UART0, but why not? Any reason that I could be aware of? Seems to be that you know the serial communication on Android and Qualcomm.


#6

Any chance to have you help me on my UART0 issue? :slight_smile:
Have a nice day.
Jean-Marc


#7

I got solution to my issue.now i am able to talk with zigbee from db410c.
Thanks!


#8

Great! what was the solution? Or the problem?

Since I do not know how to use the UART0 and for me UART1 is reserved for the console I am interested by your solution.
Thank you to give details.


#9

you mean to say,on UART1 you have console enabled.you can make that getting dmesg messages disable and you can try that UART1 for your use.I think you got idea to disable the console for UART1.


#10

Thank you for helping, sorry ta ask more.
OK great will try the use of UART1.
I do not “get an idea on how to disable UART1” console.
I am not having a good knowledge on OS and Linux.
Do you do it before compiling the system?
Can you do it on a running system? what config file?

Still asking: why you did not use UART0?