Starting sshd server on DB410C


#1

I just flashed a fresh Linaro 4.9 kernel on the dragonboard, and try to activate ssh so I can connect to it from another computer.

@danielt, I did “systemctl enable sshd; systemctl start sshd” as you wrote, but still doesn’t work.

Should we also change anything in the default configuration file at /etc/ssh/sshd_config ?


How to start sshd server
#2

That’s the solution that finally worked for me:

sudo apt-get purge openssh-server
sudo apt-get install openssh-server

#3

I’m afraid the kernel version is irrelavent for SSH. What matters is what version of the rootfs image are you running (latest is 18.01)?

AFAIK on anything recent the SSH server should be running automatically.


#4

Good question. Is there a way to check the version of the installed rootfs?


#5

There’s lots of ways to do it but personally I send to check and see
what date the kernel was compiled.

Even though you have updated your kernel the original kernel is probably
still located in /boot and you can extract the compile time from there.

Perhaps something like: