SPI Communication not working on DB410C

I have followed steps given on 96boards page to modify tree and enable Spi Com… its still not enabling SPI devices on DB410c

Does anyone know why its not wrkg…

I suspect it is caused by this:

Hi Daniel

maybe you could do a little article on adding a SPI device to the SPI bus in the device tree. The white Linker add-on board has a simple SPI connected ADC on the board. Many years ago I did ‘raw’ SPI reads/writes to use the Linker board here: https://developer.qualcomm.com/project/breakerball The powerpoint presentation has a picture of the linker board and a Python program to do raw read of the SPI ADC.

At present the simplest workaround is to replace “spidev” in the devicetree with “lwn,bk4”.

This is wrong on so many levels: you are basically misleading the kernel about what is hooked up to the SPI port in order to encourage it to do something it would specifically refuses to do if you asked it directly.

Unfortunately it’s the only way I can think of to get SPI exposed to userspace Python that doesn’t involve recompiling the kernel.

Means there is no proper way to enable SPI on dragon Board then… bcz am working with SPI sensors… so i would have to change it.

The recommended way to use SPI in Linux (for DB410C or anything else) is to activate the kernel driver for it rather than operating it from userspace via spidev. That is why the upstream Linux developers were happy to disable the feature!

To use a kernel driver you need to describe in devicetree what hardware you have attached to the SPI pins (and ensure an suitable kernel driver is enabled).