SOLVED -- SD image to EMMC


#1

Built a new image and device tree using YOCTO.

If I create an sd image from …rootfs.wic everything works great.

Now want to move image to EMMC and expand rootfs to fill the entire space.

The YOCTO image in SD has 7 partitions while the emmc Linaro image has 10 partitions.

Have tried both the dd commands and fastboot with no luck.
Apparently I’m doing something wrong.
Suggestions welcomed.
Thanks,
Steve


#2

when you build an image using meta-qcom (I assume this is what you are referring to here) you should also get a file called .ext4. That file is an EXT4 image that contains your image root file system, and it can be flashed onto the DB410c using “fastboot flash rootfs .ext4” command.

that would do exactly what you say you need. The file system size is ‘small’ (lke 1G or so), but on first boot the file system image will be automatically resize to match the size of the actual rootfs partition as it is set on the GPT of your eMMC.


#3

Thank you very much!

Also had to flash boot to get the new DTB installed.

The file system didn’t expand, but I did a resize2fs on the EXT4 file before the fastboot. My image doesn’t have resize2fs so did it before flashing. Seems to work fine.

Thanks again for your help.
Steve