SOLVED: Removing HDMI creates audio issues

custom_board

#1

Hello! (please forgive me for any style issues on this post its my first post! I am also very new to the embedded world and its been awesome so far!)

I have been working on a custom board that is based on the DragonBoard410c. The only difference between the dragonboard and my custom board is i removed all of the visual interfaces because they are not needed for my project.

I am only interested in the on the SOM audio pipeline (The apq8016 or msm8916. msm8916 is what I tend to see it named as in the drivers)

I decided to go ahead and move to the newest kernel (4.14). I use yocto (and I am on Thud). Prior to that it was on 4.4 so its a big update for this board. With this I have ran into several issues but the biggest is the OS is not noticing any of the audio hardware. In the serial interface I get errors like [ 3.920418] qcom-apq8016-sbc 7702000.sound: error getting codec dai name
[ 3.925074] qcom-apq8016-sbc 7702000.sound: Error resolving dai links: -517

I have searched all around and tested a number of solutions. The easiest was including/modularizing the adv7511 bridge (the adv7533 is the actual chip but it uses the same driver) in the defconfig and that did nothing.

The next step was disabling the adv bridge from the Device tree. I disabled that and other parts that are associated using several online resource and one of the largest was this one (SOLVED - Disable DSI/HDMI subsystem in linux) The biggest thing I have found is that as I disable parts in the device tree I get more and more errors.

I tried all different combinations of those two and I few small things like making the GPIOs up or down trying to get the audio hardware to show up.

I know that the bridge is not required (or at least it used to not be). I say that because the DART-SD410 can used the LVDS on kernel 4.9 and 4.4 which does not used the HDMI at all. I also tried to add the LDVS display to my device tree to see if it would trick the SOM into working.

any feedback or ideas are very welcomed… so that being said, any ideas???


SOLVED - Disable DSI/HDMI subsystem in linux
#2

UPDATE: This issue if fixed (I think).

So with kernel 4.14 the issue I have was “fixed” by changing to root. I turned off the HDMI and set up a LVDS display and it worked. I took the LVDS and HDMI display out of the device tree and used puTTy to go through the com port and the linaro user still gave me issues. I then used root and ran “aplay --dump-hw-params” and no issues. so I turns out that it was never really wrong.