SOLVED: Bluetooth not working properly


#1

Hello everyone,

recently I got a Dragonboard 410c, but I was not able to use it in the way I wanted. I wanted to use it to scan for bluetooth devices and pull data from specific devices. When it started scanning it behaved like it should, but when it came down to connecting to the peripheral things were going wrong. There are 2 problems:

  1. Most of the times the characteristics and service discovery fails.
  2. When it discovered the characteristics and services it disconnects while receiving notifications.

I also tried to run the application using a bluetooth dongle instead of the built in bluetooth, the application worked perfectly. It is worth noting that I did not need to install extra drivers to make the bluetooth dongle work.

logs

The logs files are quite long. I don’t really know which part(s) are relevant so I decided to upload the complete log files. To help you out a little bit, the services and characteristics are being discovered around 11:42:55, (in the hcitrace.txt and the syslog nearly at the end of the files) somewhat after that moment it starts receiving notifications and it disconnects. Before and after that moment te services and characteristics are not being discovered properly.
If you need extra information just let me know.

So if any of you do have any tips on how to make the bluetooth work, I would really appreciate that.


#2

Hello,
I ran thru the same problems and found the same solution. Using an external BT4.0 dongle.
If you kill the WIFI transmission then you can fix the issue. It is a known conflict between WIFI and BT.
But if you need the WIFI then use the dongle.
Seems to be this issue anyway: Problem when enabling Bluetooth on Dragon Board with Debian
Have a nice day.


#3

Ok thanks for the reply. Good to know that it is a known issue.
I will look into using an external BT 4.0 dongle or maybe another solution, but thanks for the help anyway.


#4

Which release are you running? As @jmjobin said there is known concurrent BT+WiFi issue on release builds, which ‘should’ be fixed in the upcoming release (and which is normally fixed in latest snapshots).


#5

I am running release 18.01


#6

I was and am still using the Debian 4.9.34-linaro-lt-qcom. Which I do not know what version would correspond.
I did not upgraded yet because I still want to see the results for the new version watching the forum :slight_smile: