SD install and boot from eMMC - installer screen does not appear


#21

Hi @signal

I have been using the 283 image, on a SDCard for quite some time to reload boards (I take boards back to factory release when I am testing instructions), but possibly something has changed. So as you suggested I have tried replicating your experience.

I re-download 283 using Chrome under Windows and checked that it is still working. Normally to extract the image file I just right click on the icon and select extract, which works fine, then I copy the 283 image from the host to the SDCard using Win32DiskImager. The SDCard I created with this flow comes up to the installer as expected.

But you are using dd, so based on this I think you have an Ubuntu host, so I need to replicate your results on a Linux box. I tried it with dd from Linux box just to be sure something else wasn’t happening. First I downloaded the file using Firefox, since this is the browser installed on the Linux box. And sure enough something else is happening when I try to unzip the file. I have tried it several times (download and unzip) with the same result. I run the command:
unzip dragonboard410c_sdcard_install_debian-283.zip
It says:
Archive: dragonboard410c_sdcard_install_debian.zip
inflating: db410c_sd_install_debian.img
error: invalid compressed data to inflate
inflating: LICENSE
I get an error from unzip, am I using the unzip wrong program? does FireFox corrupt the download? I’m not sure yet.

But unzip does leave image image file is in the directory and it looks OK. So I used dd to send it to a SDCard anyways. Unfortunately the DragonBoard doesn’t boot at all from the resulting SDCard (more on this later).

So I copied the unziped image from my Windows machine to the Ubuntu box. The file size changed from 3598581760 bytes to 4034920448 bytes. Using the same dd command I reloaded the SDCard.
dd if=db410c_sd_install_debian.img of=/dev/sdb1 bs=4M oflag=sync status=noxfer
still no sign of life. I must be doing something wrong. After thinking about where the SDCard came from (I had been using it as an ext4 file system) and re-reading the instructions I changed the dd command to:
dd if=db410c_sd_install_debian.img of=/dev/sdb bs=4M oflag=sync status=noxfer
Ha, now it boots and comes up to the installer as expected. OK, back to trying to replicate your issue.

I went back to the ‘corrupt’ img file and used dd to copy it to the SDCard (again, but this time to the correct dev). The system boots and shows the installer as expected… I tried actually installing the corrupt image, but it fails while flashing the image to eMMC.

While I am at it I need to figure out why the unzip process is creating a bad img file on Ubuntu. I copied the zip file from the Windows machine to the Ubuntu box and tried unzipping it. The zip file size is exactly the same as the one downloaded by Firefox, 111101340 bytes. This time unzipping the zip file under Ubuntu completes with no errors, so I think the problem may be with the FireFox download. The size of the unzipped file is 4034920448 bytes as it should be. I used dd to copy the img file I unziped under Ubuntu to the SDCard and tried installing. Again it comes up to installer as expected.

The MD5 for the good image file is the same as yours, so obviously you don’t have the FireFox download issue. 5b3f8cba72156aaecb0223c68b410a03

I still haven’t replicated your issue. I really do want to get you up an running so that we can improve the experience. Lets figure out what is happening and how to fix it.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#22

Hi @signal

While I was trying to replicate your issue you had more conversations with the rest of the team. based on that I have a couple of things to think about.

You are using OSX, I was trying it on Ubuntu. Unfortunately I don’t have an OSX machine so I can’t replicate that part. However it looks like your SDCard has been correctly created, so that leaves the things connected to the DragonBoard to look at.

Do you have any Mezzanine boards connected to the DragonBoard? I have seen issues where the installer won’t start if there is a mezzanine board attached.

Do you have a different HDMI monitor you can attach to the DragonBoard? The first 6 gettys are in a text mode, and only the CTL+ALT+F7 getty is running X. This is of course the one you need and isn’t working.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#23

I have used two different HDMI monitors. I am using a USB keyboard/Mouse from Apple. I am now going to try with a Logitech keyboard to see if that makes any difference. I have no Mezzanine boards attached, I have a vanilla Dragonboard 410c.


#24

I have been able to access the GUI installer. I have to plug in the board, and start continuously pressing Ctrl-Alt-F7 and it will switch over eventually. If I let it book to a tty, then switching over does not work, I have to sort of intercept it during boot…is this common?


#25

Hi @signal

Hmm… I have never seen the installer come up to a tty (and I have used many versions of the installer literally hundreds of times) so this is all new to me. Can you try booting with no mouse/keyboard connected? If you get to the installer you can then hot plug in a mouse and select what you want to install.

Boot time from power on to the installer is about 20 seconds, although this will vary depending on the speed of your SDCard.

Are you using the 12V/2A power supply provided by Arrow or something else? Does it have a yellow or a black tip? I am just trying to get to the bottom of this mystery.

P.S. did you get your board up and running from eMMC with the 17.09.1 release after you reached the installer?

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#26

hi @signal

thanks for your continued efforts. And to be clear, I never meant to say that I believe you were doing anything wrong. I’ve been around long enough to know that computers are tough beasts, and sometimes things don’t work as you would expect. I meant to say that many of us know here that this image works most of the time, and for many people. We all want to understand why it does not for you. It is definitely something to do with the setup you use (power, monitor, … ).

what is described so far doesn’t seem to make any sense, for sure. We will need more debug data. Assuming you can still reproduce the ‘wrong’ behavior, let’s try to gather some debug.

As said by Daniel, since you are seeing ‘linaro-alip’ prompt, it does mean that many things have worked well. The CPU booted off the SD card, started the Linux kernel and was able to initialize enough to power the display and bring up the console.

The very last thing that happens at the end of the boot is that we start the lightdm login manager, which in turns starts a simple X session that runs this program:

https://git.linaro.org/people/nicolas.dechesne/db410c-installer.git/tree/debian/usr/bin/96boards-installer-session?h=debian

and ‘recovery’ is the name of the GUI installer application.

So basically something went wrong between the end of the kernel init and this program.

If you reach the prompt on the monitor, please login with username linaro and passwd is linaro, then run the following commands which will dump data and write onto the SD card:

sudo mkdir /debug
sudo mount > /debug/mount
sudo dmesg > /debug/dmesg
sudo dpkg -l > /debug/dpkg
sudo systemctl status /debug/systemd
sudo ps aux > /debug/ps
sudo journalctl > /debug/journalctl 

Then, run ‘sync’ and then ‘halt’. That should turn off the system. Then insert the SD card on your PC, and locate the ‘debug’ folder and share all files with us.

thanks for your help.


#27

With no mouse/keyboard it boots to tty1. I have only been able to get the GUI one time, I have been trying for dozens of reboots now and i can’t seem to get it to come up again.

I am using a 12V 2A power supply with a plug with 1.75mm width, yellow tip, I will try another power supply to see if that helps.

When the installer came up and I tried to install, it gave a write error about 1GB into it. I have since re-imaged the SD card again.


#28

/ is mounted ro. Trying to do mount -o remount,rw / says I can’t because its “write-protected”.


#29

files are shared at https://www.dropbox.com/s/okituzsd3uxrzsi/debug.tar.gz?dl=0


#30

hi,

thanks for your patience.

looking at the boot log, it seems you are using a high speed (most likely a UHS-I one). there are lots of I/O errors when accessing the SD card and it results in re-mounting / as read only, which is very likely the root cause of the behavior you are seeing. Running a full system with read only / can bring any kind of weird issues.

Can you confirm you are using this type of card? can you try a class 10 or class 4 (non UHS) card?


#31

It is a UHS-I card. I will have to buy a Class 10 or 4 card, which I can do. So I take it UHS-I cards are not supported or not good to use?


#32

well, clearly there is a problem with this specific card. i was not expecting it. it’s a bug.


#33

@signal: Can you tell us as much as possible about the card. Things like brand, model, capacity, etc together with where you bought it.

We ran a few tests with UHS-1 cards only a month or so ago and could reproduce any problems so the extra details about the card may be useful.


#34

Yes, and I should have a new (standard) card here today to see if that fixes the issue.

The card I am using is this one:

I either bought it at Best Buy locally or Amazon. Perhaps the card is defective? If there is a test I could run on it let me know and I can try that.


#35

Here is an update. I purchased a regular SanDisk 16GB class 4, burned 283 to it using the same method I used previously (dd on OSX). It instantly booted to the installer, I flashed the eMMC, and the system has come up.

Now I am dealing with a different problem that I will research and then make a different post if I can’t resolve. My wifi says “SSID not found” even though I am typing it in correctly, and specifying the correct password and encryption.


#36

Curious. The 8GB variant of this card is the one I use every time I provision (and it works fine). Anyhow thanks for the info and I’m glad you’re past this road block now!


#37

That exactly the same card I have tested last time (sandisk ultra 16GB), booting from SDCARD and bulk read/write were ok, I did not test the sdcard-install image variant though.


#38

@danielt if anyone wants I can send them my card to test/debug with…I suppose there is the possibility its a bad card, but it may be something unique about it.


#39

Now that you could install linux image on the board, it would be
interesting to run some tests on that card. E.g. insert it while running
linux and run file I/O tests.


#40

But how can we find the source of the issue? I have just done:

sudo /sbin/badblocks -n -b 4096 -c 4096 -s /dev/mmcblk1

It’s at 36% and has is showing (0/0/12416 errors)

So yes, there are errors, something is seriously wrong. But is there any data I can gather for you that may help you understand the issue? I suppose I could do similar tests on my Mac Pro, just to show the card itself is good (or not).

Brian