SD install and boot from eMMC - installer screen does not appear


#1

the 96boards installer screen in Step 7: Install image onto DragonBoard 410c never appears. Rather it prompts with the Linaro-installer login which when using Linaro/linaro for username/password, it logs in and now what…


Debian install to eMMC not working
#2

Which image did you flash on the SD-CARD ? are you using HDMI display ?


#3

Yes I am using HDMI display. The Linaro Debian image
from http://builds.96boards.org/releases/dragonboard410c/linaro/debian/latest/


#4

Always provide full links! There are two SD card images in the directory you indicate… only one of which is an installer.


#5

I downloaded the dragonboard410c_sdcard_install_debian-260.zip to my windows PC, then used the win32diskimager to write the img to a microSD card and then set the dip switch of the board to boat from sd card as suggested. But I never get the window that has the option to install the image to the eMMC.


#6

hi, did you resolve this issue?
I have had the same with two different versions of the image


#7

Hey guys, did anyone figure this out? I’m struggling with it as well. Thanks.


#8

Yeah anyone solve this? I’ve been having the same issue


#9

What do you observe on the LEDs?


#10

If the LEDs are silent, you have not successfully copied the image to the SDCard with win32diskimager. You need to download the zip file, unzip it, then copy the .img to the SDCard. Hope this helps.

Current latest .zip file is: http://builds.96boards.org/releases/dragonboard410c/linaro/debian/latest/dragonboard410c_sdcard_install_debian-283.zip But this path will change with each new release.

In general I look in the “latest” directory for the largest file (1.1GB currently) and that’s the one to download. When you unzip it the .img file will be almost 4x larger (3.9GB currently), just by looking at the file sizes you should have an idea if you have the right files.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#11

Hi,

I have the same problem. I did the steps of installation both in Windows and Linux, but when power on the board it does not show the installer screen and it boots directly from SD card and asks Linaro-installer login username and password.

LED 1 is blinking constantly, LED 3 is solid at first and then starts to blink fast for a few seconds and then off. BT or wifi LED also blinks once.

I flashed this image of linaro-debian:
http://builds.96boards.org/releases/dragonboard410c/linaro/debian/latest/dragonboard410c_sdcard_install_debian-283.zip

I also tried to flash Ubuntu core image on db410c, and the same problem happened.
Please let me know of your comments/suggestion/ideas. Thanks.


#12

I am having the same issue, it seems the latest SD installer is broke.

Specifically dragonboard410c_sdcard_install_debian-283.zip. If you write it to an SD card, toggle the SD dip switch, and boot it, it just takes you into a linux login prompt:

linaro-installer login:

it does not give you the graphical installer where you choose an OS and “click” Install, placing the debian OS on the eMMC.


#13

I installed dragonboard410c_sdcard_install_debian-283 to my Dragonboard 410c using dd. I then set the SD boot dip switch, and the dragon board brings you to a “linaro-installer login:” prompt. You can use username “linaro” and password “linaro” and login. This is not what the instructions say you should see. The instructions make it sound like you should see a GUI just like the android image installer, where you select an OS and click “Install”. I am navigating to this page:

and simply using Option 1, to grab an image to put on the SD Card, which I then would like “installed” on the eMMC. I saw another post with this same issue, and no one had an answer. The user did not do anything wrong, they did as I did, grabbed the image, wrote it to SD card.

I suspect the latest images are not behaving properly? Does anyone know what could be going on?


#14

Hi @signal

I agree the Linaro instructions are a little confusing, they take you to too many places and have too many options. Additionally they have instructions for booting from SDCard to run Linux, and booting from SDCard to install into the eMMC.

Based on the fact that you are getting a command prompt, I think you have copied the wrong image onto your SDCard. You can figure out which image you need by looking at the file sizes. The smaller SDCard image just boots from the SDCard to a command prompt . The larger SDCard image boots to the installer screen, and then has all of the files that need to be copied over to the eMMC. You want the larger image.

For Build 283 the two files I am discussing are:

  • dragonboard410c_sdcard_install_debian-283.zip this is a 1.1G file and when unziped is about 3GB
  • dragonboard410c_sdcard_developer_debian-283.zip this is a 450M file and when unziped is about 1.4GB.

You want to copy the larger unziped file to your SDCard. As you can see it is (roughly) double the size, this is because it contains two copies of Debian, the copy it boots from, and the copy it transfers to the eMMC.

Assuming you get to the installer screen, simply select the image, and click OK to get it to copy the image onto the eMMC. After the copy is complete remove the SDCard, throw it away, and boot directly form onboard eMMC, the SDCard is no longer required.

I hope this solves your problem.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#15

I am not using the wrong file. I am using the larger 1.1GB file. If you would try to actually replicate what I am doing you will see that someone screwed up the bootloader/grub or something along those lines for this release. I in fact pasted the exact file I was using to be absolutely clear, it is “dragonboard410c_sdcard_install_debian-283.zip”.

The .img is broke, we just need someone to fix it for 283. Please advise.


#16

hi @signal,

It would be very much appreciate if the conversation can remain nice and friendly. Keep in mind that this is a community forum for 96boards.

The .img is not broken as you say. It seems to be broken in your personal situation, which means there is something wrong on your setup, or something in your setup that exhibits a new bug. As mentioned several times on the forum, when something does not work, it is really helpful when the users provide as much debug data as possible. In many cases, the UART debug log contains everything we need for a first diagnostic.

In this specific case, you indicate that you are reaching the linux prompt, but is it on the monitor, or on the UART console?

Note that the prompt “linaro-installer” confirms that you used the right image (aka the ‘installer’)


#17

It is on a monitor, connected via HDMI. I can install the Android images, no problem, from SD Card. It brings up the graphical installer, you select an image, and click install.

With the 283 debian install image, this is not the case. Things I have tried:

I completely zero’ed the SD card using /dev/zero
I used a different SD card (one is 8GB the other 16GB)
I have used bs 2M and 4M with my dd statement
I have tried to download the image from 96 boards as well as GitHub, its the same image

I do a simple dd of the image, from my OS X to the SD Card:
sudo dd if=db410c_sd_install_debian.img of=/dev/disk3 bs=2m

This is the extracted image from dragonboard410c_sdcard_install_debian-283.zip
md5 db410c_sd_install_debian.img
MD5 (db410c_sd_install_debian.img) = 5b3f8cba72156aaecb0223c68b410a03

I understand what you are saying that, you believe I am doing something wrong. With the SD card install there just doesn’t seem to be left to many things the user can do wrong. It also doesn’t seem there would normally be a way for me to do the install and end up with a “linaro-install login:” prompt, even if I wanted to, unless the boot loader was not set correctly on the image.

I am open to trying anything that may work, please advise what I could do that would be helpful to troubleshooting.


#18

There’s certainly a way to bring up the linaro-installer login: :slight_smile:

Basically when you boot the SD installer image it will (or should) create seven virtual terminals. The first six are there to run a getty (I know getty is jargon but I can’t think of a simpler term… basically a getty is the program that starts the program that shows you the login prompt) and the seventh is running the X server and the installer GUI.

Normally the system should switch to VT7 when the X server starts but either the switch didn’t happen for some reason or something (a gaming mouse?) sent keystrokes to switch to a different virtual terminal.

Anyhow…

You can press Alt-Ctrl-F1 through to Alt-Ctrl-F7 to select virtual terminals.

  • Can you switch through them OK?
  • Do you see the login prompts on #1 through to #6?
  • What do you see in #7 (check for a cursor in the top left of the screen)?

#19

Oh… and a PS…

I have confirm that a board with nothing connected except power, SD card and HDMI connected will boot and show the installer GUI with #283 (e.g. even having the mouse/keyboard missing doesn’t cause anything to break). I also suggest you try with a similarly sparten system (e.g. nothing in any USB socket) just to make sure there isn’t something plugged in via USB that is confusing the X server.


#20

I can switch between gettys on tty1-tty6, they all have logins. Attempting to switch to tty7 does nothing, it just stays on whatever tty you were previously on.