SD card not mounted by Linaro


#1

The SD card does not mount in Linaro on a 410C.
When a SD card is inserted the system generates the following error
message: mmc1: Reset 0x1 never completed.
I have tried several different SD cards that work OK in other machines but
they all fail with the same error on this DragonBoard.
Is there a workaround?


#2

hi,

which OS and which version are you using?

thanks


#3

I am using the version that was installed on the out-of-the-box IoT Starter Kit Powered by AWS. Here is some version info copied from the board.

linaro@linaro-alip:~$ cat /etc/*-release
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=debian
HOME_URL="http://www.debian.org/"
SUPPORT_URL="http://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
linaro@linaro-alip:~$

linaro@linaro-alip:~$ cat /proc/version
Linux version 4.4.8-linaro-lt-qcom (buildslave@x86-64-08) (gcc version 4.9.2 20140904 (prerelease) (crosstool-NG linaro-1.13.1-4.9-2014.09 - Linaro GCC 4.9-2014.09) ) #1 SMP PREEMPT Thu Apr 28 21:00:13 UTC 2016

If you need some other info … please advise.


#4

ok, that’s indeed an “old” release, which had this bug. I believe it is fixed in our latest releases. I don’t know if anyone has made an update to that image that was included in the AWS kit…

as far as i know the AWS image was 99% similar to the Linaro release, so you are probably better off using / re-installing the latest release:

http://builds.96boards.org/releases/dragonboard410c/linaro/debian/16.09/