SD Card boot not working



I installed ubuntu following instructions, on a 128GB SD card. Plug it into the device, turns it on, but nothing boots. Screen remains black (as if in Maskrom mode).

I tried installing debian on the sd card, same results.

Any ideas how to fix this?

edit: after installing debian, and then ubuntu on the eMMC, booting completely bypasses sd card, and boot directly into ubuntu (eMMC), and does not get ‘stuck’ on the black screen.

Some wireless issue with current Linux 4.4 kernel

Do you have an older SD card you can try… SD cards have many different generations (which translates to different clock speeds for data xfer) and it is not uncommon for boards to have problems with very new cards.

If you have an older 16GB card lying around it would be a useful experiment to try with that, even if just to eliminate the card from your enquiries!


Hi Daniel.

When i do blkdiscard /dev/mmcblk1 (ie. eMMC), sdcard with debian boots, however sdcard with ubuntu doesn’t boot. serial console shows some panic code.

When I have debian or ubuntu installed on eMMC, neither debian nor ubuntu installed on sdcard will load.


Then you should put that in a pastebin or github gist!

Always share logs if you have them. It encourages better answers.


It boots from sdcard only if I modify mmcblk1p4 partition (this is the eMMC dev), specifically extlinux.conf to “append earlyprintk console=ttyFIQ0,1500000n8 rw root=/dev/mmcblk0p5 rootfstype=ext4 init=/sbin/init rootwait”.

Note i changed “root=/dev/mmcblk1p5” to “root=/dev/mmcblk0p5”.

The above will boot only if SD card is inserted. If I edit the extlinux.conf file on eMMC back to “mmcblk1p5”, then it will boot back from the eMMC.

Also worth noting that if I erase the eMMC completely, it will boot from sdcard.

Is there anyway to prioritise loading extlinux.conf from sdcard (mmcblk0p4) over eMMC (mmcblk1p4)? That way, it will boot eMMC when sdcard is not present, or boot sdcard when sdcard is present.


Hey, having the same problem on the Rock960 Pro. Have tried flashing the Ubuntu Server 16.04 image from GitHub but to no avail. I’m going to try to eMMC flash it, but I was hoping to get it up an booted with minimal work. I’ll comment about if it works and any work arounds I’m using.



To meet your requirement, you can just add root=PARTUUID=b921b045-1d for the kernel command line. This will work as you wish since kernel will always look for mmcblk0 first when looking for partition with uuid=b921b045-1d, so mmcblk0p5(sdcard) will be mounted instead of mmcblk1p5(eMMC). If no sdcard, mmcblk1p5(eMMC) with uuid=b921b045-1d will be mounted.