[Rock960] Issue about using rkdeveloptool to flash eMMC


#1

I followed instructions in this article.

lsusb command in my Ubuntu14.04 desktop environment shows:

Bus 003 Device 006: ID 2207:0011

But when I try rkdeveloptool with argument ld it comes:

not found any devices!

I added some code:

config.emDeviceType = RKNONE_DEVICE;
config.usPid = 0x0011;
config.usVid = 0x2207;
m_deviceConfigSet.push_back(config);

in the source code of rkdeveloptool project and rebuilt it. Then rkdeveloptool with argument ld works, it shows:

DevNo=1 Vid=0x2207,Pid=0x11,LocationID=30b Maskrom

But rkdeveloptool with other arguments such as td still not work fine. It puts information like creating comm object failed in the terminal.

:disappointed_relieved:


#2

This is usually a permissions failure. Did you follow the troubleshooting advise at the bottom of the article?


#3

Yelp. I use root user to run rkdeveloptool but still not work.


#4

If no permission issue, it might be a hardware issue. Check your usb cable or usb ports on the motherboard/laptop. Also use a usb 2.0 cable helps. The communication for maskrom uses only usb 2.0 signals.


#5

USB2.0 still not work.


#6

@hipboi @danielt
Thanks for your time!

I tried many times but things seem not good.

Finally, I quit. I flashed the Ubuntu system image to a Mirco SD card and boot my board from that SD card.

PS: I’ll try the Flashing to eMMC method later and I’ll update this post if I have any progress.


#7

OK. Once you are running on sdcard, you can copy the image to udisk or sdcard, and dd it to eMMC (/dev/mmcblk1), then power off and remove sdcard. It should boot from eMMC.


#8

That’s very helpful! Thanks again!:grinning: