Restore HiKey 620 board to factory bootloader

Hello all,

A few months ago experimented with getting OPTEE running on my HiKey board so my board now has an UEFI bootloader. This has worked fine.

Now that this is done, I’m trying put regular Android back on it, without really any need for OPTEE. In fact, I would like to be able to follow those instructions:

https://source.android.com/setup/build/devices#620hikey

To get Android to work. Unfortunately, I have gathered by searching this forum that UEFI is interfering with this because if I follow those instructions, I get the following error in my serial console:

Press ESCAPE for boot options .ERROR: Device Tree header not valid (err:-9)

Is there a way I can restore the factory bootloader on my HiKey board? I’ve found that this is possible for HiKey 960/970 but I didn’t find an equivalent for HiKey 620.

If this is not possible or no longer supported, I would like the some instructions or guidance on how to get an UEFI bootloader on the board and then how Android should be properly flashed on it?

Thank you in advance.

The bootloaders are actually in the Android device tree.

https://android.googlesource.com/device/linaro/hikey/+/refs/heads/master/installer/hikey/README

I’ve followed those instructions several times and I still get UEFI as bootloader. I guess that means this is the default bootloader, I don’t mind this.

What troubles me is that the instruction at the page https://source.android.com/setup/build/devices#620hikey invariably leads to the boot process complaining about the DTB header being invalid. I presumed this was because of my experiments with OPTEE, but since UEFI seems to be the way to go, I would like to have updated information on how to get the AOSP to work on my HiKey device.

JFYI:

Leads to a page saying the link has moved. The fixed link from that page is not found.

If AOSP isn’t booting, then try building from a known good manifest: