Reading UART0 on HiKey LeMaker 620 Board

I am trying to read the UART0 stream on the HiKey 620 LeMaker version board. Since I don’t get any output when using UART3, I connected my USB-UART cable to UART0 as described in the LeMaker wiki. While I get output now, most of the stuff is not readable, maybe due to wrong encoding or a faulty baud-rate? I get things like 8C�@@����p�x@. While there are some readable symbols and words in there, most of them are not. I flashed the hikey.xml and changed the uart_cfg to 0 in the makefile. Are there any other configurations I could adjust here to read the “correct” characters?

Thanks for your help!

PS: I use the minicom tool on linux to display the output.

UART3 is the default, so that’s where you should be seeing output rather than UART0. Please provide details on how the connections are made.

hikey.xml is not something you flash to the board. Please provide more details here too like which repositories/guide you’re using and what commands you’re running.

We see some output on UART3 but its also the unreadable chars.

I followed the guide: With UART0 I can type in the password “linaro” and some commands like ls and i can see sbin etc. But the most characters are unreadable.

I monitor the UART stream with sudo minicom -b 115200 -o -D /dev/ttyUSB0 and I changed some settings like hardware flow control off.

How are you connecting to uart3?

For minicom, any reason to use the -o option? Can you try just minicom -s and going into the options and set manually 115200 8n1 and no flow control for both hw and sw?

I just tried the minicom -s and set the options manually. I get the same unreadable output as before.

Here is picture how i connected the UART3 to USB adapter.

What kind of usb adapter are you using? Make sure it’s good for 1.8v and not 3.3v or 5v.

Also, you might want to try following to make sure everything is working well before trying to create and flash images of your own?

Hey vchong,

sorry for the late response. The UART Adapter finally arrived today (after 3 weeks of clearance) and it works. Thank you for your help! :slight_smile: