Reached kernelconfig for the grove sensor & can't fastboot


#1

Hi guys

I followed the exact instructions here:
http://www.96boards.org/forums/topic/interfacing-i2c-grove-digital-light-sensor-on-dragonboard-410c/

I use a macbook pro with OSX EL Capitan 10.11.1 on it. I access Ubuntu remotely and built the kernel.I got to the kernel configuration screen and everything worked fine.

Then I used the instructions here in section 3.3 to program Android images using fast boot:

But when I give the give the command: $ sudo fast boot devices
The mac terminal just kept searching for devices and could never find the board even though the dragon board popped up when I gave the the command: $ adb devices
and got:
adb devices
List of devices attached

  • daemon not running. starting it now on port 5037 *
  • daemon started successfully *
    ba5f2518 device

Thus I know that the board is connected. But I still can’t build the kernel on it. Is it because I built the kernel remotely? If so, how do I get around this issue?

Thanks
G


#2

Hi @gulmoharahluwalia,

I am not completely sure but it could be just typo on your command line.

Could you try


$ sudo fastboot devices

without having space between “fast” and “boot”.


#3

EDIT: I did actually try ‘sudo fast boot devices’. I made a typo while typing the original post. It still gives the same error as mentioned in the original post where in it just keeps trying to find devices but cant find any.


#4

Just to double check, have you followed the instructions in step 1 of section 3.3 to get into fastboot mode?


#5

Hi vchong

I did try the first step. This is what happens:
$fastboot devices
$cd desktop/bin (THIS IS THE PLACE WHERE I EXTRACTED THE /device/out/host/linux-x86/bin directory after zipping it and downloading it from the remote Linux machine that I access via ssh)

$ fastboot flash aboot desktop/SDown/emmc_appsboot.mbn
< waiting for any device >

Then I never end up finding a device. Also note that I ran these commands on my host macbook OSX after downloading the /device/out/host/linux-x86/bin directory from the remote Linux machine.


#6

I mean step 1 as in holding down the VOL- key and applying power to the board to get it into fastboot mode.

"
3.3 Program Android images using fastboot

  1. Hold down the VOL- key, connect the DC supply to the DragonBoard 410c, and press the power ON button. Plug the USB cable into the target. This will bring the device into fastboot mode.
    "

#7

Yes I’ve tried that.Please note that the kernels were compiled remotely on Linux and then Mac OSX El Capitan 10.11.1 is being used as the host to fast boot after copying the files the kernel built in Linux generated remotely.


#8

I just tried it on my osx and have no problem getting into fastboot mode.


&gt; fastboot devices
bde62310	fastboot

If possible, try checking your (board’s) console to see if it’s booting up into fastboot mode properly. Here’s mine (the last few lines):


Android Bootloader - UART_DM Initialized!!!                                                                            
[0] [0] welcome to lk
[10] [10] platform_init()
[10] [10] target_init()
[40] [40] SDHC Running in HS200 mode
[60] [60] Done initialization of the card
[70] [70] pm8x41_get_is_cold_boot: cold boot
[70] [70] No &#039;frp&#039; partition found
[70] [70] Not able to search the panel:
[80] [80] Display not enabled for 24 HW type
[80] [80] Target panel init not found!
[80] [80] pm8x41_get_is_cold_boot: cold boot
[90] [90] fastboot_init()
[90] [90] Loading keystore failed status 5
[200] [200] USB init ept @ 0x8f698000
[220] [220] udc_start()
[320] [320] -- reset --
[320] [320] -- portchange --
[500] [500] fastboot: processing commands

Compiling remotely and transferring the files over to your mac (which is fine by the way and something that I do too all the time) will not affect getting into fastboot mode or not.

Just to be sure, you have the micro USB connected but none of the USB Type A (the 2 big regular USB) connectors connected, right? Don’t think this is the cause anyway, but just want to rule it out.


#9

Hey,

Could you please explain how you checked if your board was booting up into the fast boot mode properly?

Also, I don’t get that message that you just put up there. I don’t get anything in fact. This is exactly what happens for my fastboot devices:

Georginas-MacBook-Pro:bin Gims$ fastboot devices
Georginas-MacBook-Pro:bin Gims$

Also, are you using a UART connection, perhaps a 5 pin one with the expansion connector, perhaps something like this?:
http://www.hardkernel.com/main/products/prdt_info.php?g_code=G134111883934


#10

Hi @gulmoharahluwalia,

Booting DB410C in fastboot mode is a bit tricky.

There is more easier description about booting DB410C in fastboot mode.
Please refer "Step 3: Boot DragonBoard™ 410c into fastboot mode"
http://www.96boards.org/documentation/ConsumerEdition/DragonBoard-410c/Installation/LinuxFastboot.md/


#11

Yes, you check the boot logs using a UART connection. I use http://www.96boards.org/products/mezzanine/uarts/, along with a microUSB-to-USB cable. There are other options available, but this seems the easiest, most common and possibly even most cost effective. The one you posted will be hard/tricky to connect to the LS expansion port, i.e. looks like it will involve some wire cutting, and no guarantee that it will work as well.


#12

Thanks @vchong , I’ll try that and see how I go.

@Akira Tsukamoto I could enter the fast boot mode as per the step 3 of the instructions you gave me but I can’t exit fast boot mode and boot up the board again.
My adb connection has has disappeared and the dragon board doesn’t show up in adb devices.I’ve also tried holding the power + s3 +s4 to reboot according to the instructions here but nothing has worked: https://forums.oneplus.net/threads/how-to-exit-fastboot-mode.50986/

So no LED lights up on the board and nothing happens when I connect the board to a monitor via hdmi. I tried turning the power on and off again but no avail. But when I connect the board to my mac and ask for: fast boot devices, it still shows up:

$fastboot devices
ba5f2518 fastboot

Would you know how to work around this?


#13

Have you tried just rebooting the board without holding down any buttons? Or issue the fastboot reboot command from your pc, again without holding down any buttons on the board? Also make sure that the S6 switch is on all 0s.


#14

I’ve already tried all that and all my s6 switches are on zero.
Thats what I get when I fast boot reboot:

Georginas-MacBook-Pro:bin Gims$ fastboot reboot
rebooting…

finished. total time: 0.005s

I still can’t see the board on adb devices and just as mentioned previously: no LEDs light up and nothing happens on power up/power down or by holding the buttons. Is there anything else I can do?


#15

Maybe the flashing process didn’t go well for some reason and something got corrupted. Try finishing steps 4-8 of the instructions Akira gave you.


#16

The steps @Akira gave me were to boot up a Linux image, I’m dealing with a slightly different problem. I did however tried booting up all the images listed in step3 here which is pretty similar to the instructions Akira gave me: https://developer.qualcomm.com/qfile/28828/lm80-p0436-2_sw-build-and-install_gd_linux_android.pdf

But it still doesn’t work. The same result: The fast boot of all these images was successful but I can’t reboot normally and no LED’s or anything lights ups when I connect the board to a monitor via HDMI.

Any other tips/help would be greatly appreciated.

Thanks
G


#17

The steps Akira gave contain options for both Linux or Android image.

If all else fails, try a board recovery here - http://www.96boards.org/documentation/ConsumerEdition/DragonBoard-410c/Installation/BoardRecovery.md/.


#18

Hi @vchong

I tried following Akiras instructions but they didn’t work. I couldn’t boot up android properly after a kernel build.

Also I tired the recovery instructions you gave me, I set up android normally using those instructions. Then I went back to following the instructions to transfer my own kernel build according to Akiras instructions but I failed.

Any advice on how to resolve this?


#19

Can you describe how exactly are you building your own kernel and transferring it? Akira’s instructions, i.e. the link http://www.96boards.org/documentation/ConsumerEdition/DragonBoard-410c/Installation/LinuxFastboot.md/ that he provided above, don’t cover kernel building.


#20

Hi @vchong

I am just using @ldts-atsuka 's instructions to transfer the kernel changes that I have made onto the dragon board using fast boot.

The following are the instructions that I use for the kernel built that I use (and have been adapted from tis video https://www.youtube.com/embed/1c3Epva9hCc?rel=0&width=560&height=315&wmode=transparent&iframe=true&autoplay=1 ):

  1. Make sure you have Python 2.7, Ruby tools

  2. Navigate to this page, find your suitable dragon board release
    https://wiki.codeaurora.org/xwiki/bin/QAEP/release

We are installing repo using:http://source.android.com/source/downloading.html
$ mkdir ~/bin
$ PATH=~/bin:$PATH

$ curl https://storage.googleapis.com/git-repo-downloads/repo > ~/bin/repo

$ chmod a+x ~/bin/repo

  1. Create an empty directory to hold your working files on a case-sensitive filesystem. Give it any name you like:
    $ mkdir WORKING_DIRECTORY
    $ cd WORKING_DIRECTORY

  2. Configure git with your real name and email address. To use the Gerrit code-review tool, you will need an email address that is connected with a registered Google account. Make sure this is a live address at which you can receive messages. The name that you provide here will show up in attributions for your code submissions.
    $ git config --global user.name “Your Name”
    $ git config --global user.email "you@example.com"

  3. Run repo init to bring down the latest version of Repo with all its most recent bug fixes. You must specify a URL for the manifest, which specifies where the various repositories included in the Android source will be placed within your working directory.

  4. Install gnupg: https://www.gnupg.org/download/index.html

  5. $ repo init -u https://android.googlesource.com/platform/manifest
    To check out a branch other than “master”, specify it with -b. For a list of branches, see Source Code Tags and Builds.
    $ repo init -u https://android.googlesource.com/platform/manifest -b android-4.0.1_r1

A successful initialization will end with a message stating that Repo is initialized in your working directory. Your client directory should now contain a .repo directory where files such as the manifest will be kept.

  1. Depending on the dragon board android release version do this:
    $ repo init -u git://codeaurora.org/platform/manifest.git -b release -m LA.BR.1.1.2-01420-8x16.0.xml --repo-url=git://codeaurora.org/tools/repo.git --repo-branch=caf-stable

  2. Since I’m using 8 cores on a remote super computer running linux, i use ‘j-8’ lil that:
    $ repo sync -j8

  3. Source build/envsetup.sh

Run $ lunch
Select 30

Please tell me if what I’m doing is okay?