RB5 no HDMI output after recent firmware/Debian install

I just trying moving from the Thundercomm images to Linaro because I need a newer Kernel to support the CANFD chipset on the RB5. I’ve followed all the instructions and everything worked fine (I ran board recovery to use fastboot, then flashed the bootloader and rootfs with no issues). I can find the linaro machine on my network and ssh to it. Just the HDMI does not seem to work. I know this HDMI cable, monitor, and the HDMI hardware on the RB5 work because I was just viewing the Ubuntu login from the Thundercomm image an hour ago. I did change my dip switches from 110000 to 011000, hoping that might help turn on something during boot but that didn’t work either. Any help would be appreciated.

hey!

Did you noticed the special section “Updating LT9611UXC firmware” in the release notes?

http://releases.linaro.org/96boards/rb5/linaro/debian/21.08/

I certainly did not see that. Thanks!

Unfortunately, that echo command doesn’t work for me, even as root. But I’ll keep digging with that knowledge.

Yeah, I can’t seem to get the instructions to start the firmware upgrade to work.

root@linaro-gnome:/home/linaro# cat /sys/bus/i2c/devices/5-002b/lt9611uxc_firmware
40
root@linaro-gnome:/home/linaro# echo 1 > /sys/bus/i2c/devices/5-002b/lt9611uxc_firmware
bash: echo: write error: No such file or directory

I found that the Debian rootfs does not include the lt9611uxc_fw.bin needed to actually upgrade the firmware. I had to download it from here: https://anduin.linuxfromscratch.org/sources/linux-firmware/lt9611uxc_fw.bin and copy it into the Debian /lib/firmware directory for the update to start

hey Patrick,

I think you’re right. Sorry about that. The lt9611 firmware was added in debian, misc-nonfree: add lontium bridge firmware (02399e28) · Commits · Debian kernel team / firmware-nonfree · GitLab, but it’s not in our image.

We will fix that for next release.