Problems with linaro-stretch-developer-hikey-20180828-19


#1

Hi everyone,

I’ve been trying to follow the installation tutorial from here: https://www.96boards.org/documentation/consumer/hikey/hikey960/installation/linux-fastboot.md.html

I got stuck when booting in the normal mode (Switch 1 ON, 2 and 3 OFF).
It seems that things started going wrong at this point:

[    2.847883] mmc1: new SDIO card at address 0001
[    3.741869] ufshcd-hisi ff3b0000.ufs: ufshcd_query_flag: Sending flag query for idn 3 failed, err = -11
[    5.277866] ufshcd-hisi ff3b0000.ufs: ufshcd_query_flag: Sending flag query for idn 3 failed, err = -11
[    5.287269] ufshcd-hisi ff3b0000.ufs: ufshcd_query_flag_retry: query attribute, opcode 5, idn 3, failed with erros
[    6.813868] ufshcd-hisi ff3b0000.ufs: __ufshcd_query_descriptor: opcode 0x01 for idn 8 failed, index 0, err = -11
[    8.349866] ufshcd-hisi ff3b0000.ufs: __ufshcd_query_descriptor: opcode 0x01 for idn 8 failed, index 0, err = -11
[    9.885855] ufshcd-hisi ff3b0000.ufs: __ufshcd_query_descriptor: opcode 0x01 for idn 8 failed, index 0, err = -11
[    9.896128] ufshcd-hisi ff3b0000.ufs: ufshcd_read_desc_param: Failed reading descriptor. desc_id 8, desc_index 0,1
[    9.908484] ufshcd-hisi ff3b0000.ufs: ufshcd_init_icc_levels: Failed reading power descriptor.len = 98 ret = -11
[   31.004986] ufshcd-hisi ff3b0000.ufs: ufshcd_print_pwr_info:[RX, TX]: gear=[1, 1], lane[1, 1], pwr[SLOWAUTO_MODE,0
[   31.018090] ufshcd-hisi ff3b0000.ufs: UPIU[0] - issue time 9918352 us
[   31.024529] ufshcd-hisi ff3b0000.ufs: UPIU[0] - complete time 0 us
[   31.030708] ufshcd-hisi ff3b0000.ufs: UPIU[0] - Transfer Request Descriptor phys@0xdf058000
[   31.039065] UPIU TRD: 00000000: 15000000 00000000 0000000f 00000000
[   31.045330] UPIU TRD: 00000010: df040000 00000000 00800080 01000001
[   31.051595] ufshcd-hisi ff3b0000.ufs: UPIU[0] - Request UPIU phys@0xdf040000
[   31.058643] UPIU REQ: 00000000: 00d04001 00000000 00000000 24000000
[   31.064908] UPIU REQ: 00000010: 00000012 00000024 00000000 00000000
[   31.071173] ufshcd-hisi ff3b0000.ufs: UPIU[0] - Response UPIU phys@0xdf040200
[   31.078308] UPIU RSP: 00000000: 00000000 00000000 00000000 00000000
[   31.084573] UPIU RSP: 00000010: 00000000 00000000 00000000 00000000
[   31.090838] UPIU RSP: 00000020: 00000000 00000000 00000000 00000000
[   31.097102] UPIU RSP: 00000030: 00000000
[   31.101022] ufshcd-hisi ff3b0000.ufs: UPIU[0] - PRDT - 1 entries  phys@0xdf040400
[   31.108505] UPIU PRDT: 00000000: 1861a000 00000002 00000000 00000023
[   31.258263] ufs final power mode: gear = 3, lane = 2, pwr = 1, rate = 2
[   31.267334] ufshcd-hisi ff3b0000.ufs: ufshcd_print_pwr_info:[RX, TX]: gear=[3, 3], lane[2, 2], pwr[FAST MODE, FAS2
[   31.279890] Freeing unused kernel memory: 1152K
Loading, please wait...
starting version 232
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
Begin: Waiting for root file system ... Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
[   42.483257] random: crng init done
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
done.
Gave up waiting for root file system device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT!  UUID=4be2a8aa-b08f-4446-a223-f77e31460c8e does not exist.  Dropping to a shell!
(initramfs) 

It seems like someone has had the same problem here: how-to-get-debian-working/6469 , but I can’t find the hynix patch

git clone git@bitbucket.org:snippets/siteks/eaz9Gp/hynix_patch.git

To execute the same steps.


#2

link for the missing hynix patch How to get Debian working


#3

Hi,

Please see the link for ufs hynix fixing for kernel 4.9: https://android-review.googlesource.com/c/kernel/hikey-linaro/+/614658;

On the right side of the web page, it also contains the links for the patch for kernel 4.4 and 4.14.


#4

I think I’ve managed to include that, and it boots if I change the grub setparams to:

setparams ‘Debian 9.0 (Stretch)’

linux /boot/Image_new console=tty0 console=ttyAMA6,115200n8 root=/dev/s\|

dd10 rootwait rw efi=noruntime
devicetree /boot/hi3660-hikey960.dtb

But then I got stuck in the login, it seems that the serial is not responding. If I type anything the cursor stops blinking and when I press “enter” nothing happens.

Debian GNU/Linux 9 hikey960 ttyAMA6

hikey960 login:


#5

Hello,

Please try our new snapshot image for HiKey960, it has the Hynix UFS fix integrated.