Problem in Device detection & flashing


#1

Hi ,
I have got new Dragon Board 410c -
I have tried with pre-builds device is up and working fine Display seen in HDMI monitor.

Actual problem :
I have downloaded code from codeaurora site as below links
https://us.codeaurora.org/xwiki/bin/QAEP/WebHome
https://us.codeaurora.org/xwiki/bin/QAEP/release - version - LA.BR.1.2.4-06210-8x16.0.xml
code downloading & building without any issue.

coming to flash…
I have kept device in fastboot mode [press (-) volume button + power button ]
fastboot devices
eg: it is shown serial number as fasboot mode

I have flashed images using below commands :
sudo fastboot flash aboot emmc_appsboot.mbn
sudo fastboot flash boot boot.img
sudo fastboot flash system system.img
sudo fastboot flash userdata userdata.img
sudo fastboot flash recovery recovery.img
sudo fastboot flash persist persist.img
sudo fastboot flash cache cache.img

rebooted device
waited fro 5-10 min it going to recover mode … alway

2 times tried different combinations once prebuilds later my own build image
finally device not detecting in Ubuntu PC and not going to fastboot mode also

Any one have idea what is went wrong here … could you please help me out


#2

Hi @amarnadh,

Would it be OK for trying the Android from these links?

This is installing prebuild AOSP for DragonBoard 410C.

This is the instruction of building the AOSP for DragonBoard 410C from source.


#3

Hi AkiraTsukamoto

Thanks for your help.

I was new to porting , how to flash firmware on Dragon 410c Board.
Because Board is not switching to fastboot mode [Major problem]

Current status of Dragon 410c Board - Device is detected as /dev/ttyUSB0 in Ubuntu PC but in minicom no control it show only box type of junk characters. Any space /enter keys are not consumed from minicom

-Regards
Amar


#4

Hi @amarnadh,

If you can see /dev/ttyUSB0 then,
please try


$ minicom -b 115200 -o -D /dev/ttyUSB0

And if the above still do not let your typing going through, it is highly possible that the “Hardware Flow Control” is turned on.
To turn it off, change the setting by typing
Ctrl-A Z, -> O [Configure Minicom] -> Serial Port Setup -> Options F.


#5

software@TESOFTWARE:~$ minicom -b 115200 -o -D /dev/ttyUSB0

Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Jan 1 2014, 17:13:19.
Port /dev/ttyUSB0, 15:20:37

Press CTRL-A Z for help on special keys

Still junk character seen …
By default - “Hardware Flow Control” is turnoff - i did once again on and off both same thing… no difference observed.

-Regards
Amar